VirtualBox

Ticket #649 (closed defect: fixed)

Opened 7 years ago

Last modified 4 years ago

Shared folder regressions in 1.5.x -> fixed in 1.6.2/SVN

Reported by: sandervl73 Owned by:
Priority: critical Component: shared folders
Version: VirtualBox 1.5.0 Keywords:
Cc: Guest type: Windows
Host type: other

Description

Please report all regressions found in the 1.5.0 release here.

Change History

comment:1 Changed 7 years ago by victor

Browser mode works great now, it is more convenient than before! It is also a great feature that the permanent shared folder can be added when guest system is running.

So grateful for your great work, you make life really easy.

host: ubuntu feisty i386 guest: windows xp (fresh install with additional tools)

1.It always pops up a warning message said that "the files is being accessed by another program" when I try to access the files which have just been copied to the shared folder. It works well after rebooting the guest system.

2.All kind of ms office file can't be opened directly from the network neighborhood, doc & xls files can be opened after mapping the network drive, but the ppt file still can't be opened.

comment:2 Changed 7 years ago by victor

3.The guest system need to be reboot after mapping a new network drive, or the doc & xls files can't be saved to the new mapping drive.

comment:3 Changed 7 years ago by boga

Same host/guest configuration, Orcad Capture 7 fails to open files from a mapped shared folder.

comment:4 Changed 7 years ago by imcon

VirtualBox 1.4 and 1.5 Host: WinXP Guest: Win2000 - sharing Ok; WinXP no possible to see shared folder,

I tryed to reinstall GuestAdditions, Tryed to restart, no chance, sharing Win2000 works fine but on guest WinXp nothing

comment:5 Changed 7 years ago by ugunt

I can see folders on VBOXSRVlocal and can copy files from there but I cannot access files directly from winword (or other programs, I also tried endnote). If I mount a samba share this is different, I can directly open files from word.

comment:6 follow-up: ↓ 13 Changed 7 years ago by sandervl73

Powerpoint regression (unable to open files) with Linux guest fixed in SVN.

comment:7 Changed 7 years ago by thom4s

I use Ubuntu 7.10 as host. I create a 'shared folder' in VirtualBox GUI. I start the guest OS (Windows XP Home SP2).

Then I type this in XP console: net use x:\vboxsrv\sharename

I get: Systemerror 67 - Can't find networkname (this is a translation)

When using Explorer I can see the VBox network but when I attempt to browse it I get this error: 'Could not access network, command not supported' (also translation).

I'm 100% sure the sharenames are OK. Sorry I can't give the exact errors because I'm running Dutch language.

comment:8 Changed 7 years ago by sandervl73

  • Summary changed from Shared folder regressions in 1.5.0 to Shared folder regressions in 1.5.x

comment:9 follow-ups: ↓ 11 ↓ 12 ↓ 15 Changed 7 years ago by BDKMPSS

non-admin users on Windows Guests can't "establish" a connection to shared folders. A user with admin privileges has "established" it at first, then limed users can access it.

Some more explanation: I have some virtual Machines with Windows Guests. There is always an administrator account and one user account which has Main-User (? it is called "Hauptbenutzer" in German) privileges. A (host) folder is mapped to x: via the shared folder function. If I start the machine and log on as the user a message pops up saying that \vboxsvr\*someShare* is not available (as windows tries to remap all the networkshares which were mapped before). Same msg appears if I manually try to open the x: "drive". If I than log out and log in as administrator or log in as administrator right after startup (which has the same share mapped to the same "drive") the share works fine. If I now log out and log in as user the very same share/"drive" which failed before works fine now, which is really annoying.

tested Hosts: Windows XP Pro SP2, Debian Linux

tested Guests: Windows XP Pro SP2, Windows 2k Pro Sp4

tested user privileges: Main-User, User, Guest

this affects at least virtualBox 1.5.2 and I am pretty sure worked in 1.4.0. Always had matching Addition installed.

comment:10 Changed 6 years ago by masoris

Shared folders doesn't appear in Network Explorer on Windows Vista: #799

comment:11 in reply to: ↑ 9 Changed 6 years ago by radoslaww

Replying to BDKMPSS:

The same is with windows 2000 guest, virtualbox 1.5.2. Shared folder couldn't be accessed by ordinary user (without administrator priviledges) if administrator didn't log in before.

comment:12 in reply to: ↑ 9 Changed 6 years ago by BDKMPSS

Replying to BDKMPSS:

Still the same with 1.5.4

comment:13 in reply to: ↑ 6 Changed 6 years ago by schuetzm

Replying to sandervl73:

Powerpoint regression (unable to open files) with Linux guest fixed in SVN.

In VirtualBox 1.5.4 with current Guest Additions (Host: SuSE Linux 10.1; Guest: Windows 2000 SP4 German), the following problems can be observed:

  • Opening a file from a shared folder with any MS Office program is only possible in read-only mode (File "..." is being used by user "..."; Do you want to open a read-only copy?)
  • Sometimes not even opening R/O is possible (Word cannot open "...": The user does not have sufficient permissions); the file that it tries to open is owned by the Linux user running VirtualBox and has permissions 644.
  • When trying to save a file from any MS Office program, after entering the file name in the "Save As" dialog and pressing "Save", a message box appears saying "The process has been completed successfully". After that, the save dialog box stays open, and the file has been created with size 0 and permission 600.
  • Trying to save it again sometimes works, but sometimes produces the following error: "The file could not be saved, because it is being used by another user... [Retry] [Cancel]". In this case, a temporary file is created (e.g. ppt9.tmp) in the target directory, which is not deleted even after MS Office is closed.

comment:14 Changed 6 years ago by inacoma

sandervl73 explained it to a "T". Still having issues with 1.5.6 using Ubuntu Host 7.10 and Windows Guest (winxp). Hope this gets fixed soon, as it is critical for it to work with shared folders, or I have to go back to VMware :(

comment:15 in reply to: ↑ 9 Changed 6 years ago by BDKMPSS

Replying to BDKMPSS:

non-admin users on Windows Guests can't "establish" a connection to shared folders. A user with admin privileges has "established" it at first, then limed users can access it.

Some more explanation: I have some virtual Machines with Windows Guests. There is always an administrator account and one user account which has Main-User (? it is called "Hauptbenutzer" in German) privileges. A (host) folder is mapped to x: via the shared folder function. If I start the machine and log on as the user a message pops up saying that \vboxsvr\*someShare* is not available (as windows tries to remap all the networkshares which were mapped before). Same msg appears if I manually try to open the x: "drive". If I than log out and log in as administrator or log in as administrator right after startup (which has the same share mapped to the same "drive") the share works fine. If I now log out and log in as user the very same share/"drive" which failed before works fine now, which is really annoying.

tested Hosts: Windows XP Pro SP2, Debian Linux

tested Guests: Windows XP Pro SP2, Windows 2k Pro Sp4

tested user privileges: Main-User, User, Guest

this affects at least virtualBox 1.5.2 and I am pretty sure worked in 1.4.0. Always had matching Addition installed.

"Shared folder couldn't be accessed by ordinary user (without administrator priviledges) if administrator didn't log in before" is still true with version 1.5.6 and is extremely annoying in a MS Windows Vista Guest, as even the "Administrator" Users are limited via UAC and the only way I found to enable it is to do a "net use x: \vboxsvr\share" in a privileged "cmd"-Window after reboot.

comment:16 Changed 6 years ago by BDKMPSS

Same regession in 1.6.0...

this makes it almost unusable

comment:17 Changed 6 years ago by sandervl73

The admin issue is still on the todo list.

comment:18 Changed 6 years ago by sandervl73

  • Summary changed from Shared folder regressions in 1.5.x to Shared folder regressions in 1.5.x -> fixed in 1.6.2/SVN

The admin problem has been fixed. Wait for 1.6.2.

comment:19 Changed 6 years ago by jwithana

when can we expect 1.6.2? will 1.6.1 come first or will you go straight to 1.6.2?

comment:20 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

comment:21 Changed 6 years ago by Divius

  • Status changed from closed to reopened
  • Resolution fixed deleted

1.6.2 didn't fix the problem. Host: Mandriva 2008 Spring Guest: Windows Xp SP2 A user with administative rights cannot get access to shared folders (cannot find host). Reinstallation of "Guest additions" resolved problem.

comment:22 Changed 6 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to fixed

Administration right problems are discussed in 1680.

comment:23 Changed 6 years ago by sandervl73

And guest additions problems will never be fixed unless you update the guest additions inside the VM.

comment:24 Changed 6 years ago by Divius

I used latest available version (1.6.2). I didn't need to update anything because I'd created the VM from scratch. Well if you don't want to correct your error...

comment:25 Changed 6 years ago by sandervl73

It's already fixed as mentioned in 1680.

comment:26 Changed 6 years ago by Divius

No it isn't. It works only after reinstallation.

comment:27 Changed 6 years ago by sandervl73

Let me rephrase then: we have fixed it in our internal code repository.

comment:28 Changed 6 years ago by Divius

Oh, now I got it. Excuse me)

comment:29 in reply to: ↑ description Changed 6 years ago by georgeen

  • Status changed from closed to reopened
  • Resolution fixed deleted

Replying to sandervl73: This issues doesn´t be closed yet, on WinXP host with WinXP VM the shared folders doesn´t appear and when appear sometimes the virtual machine crash and after some crashes the virtual hard disk is damaged and in the host NTFS reports that $Mft has problems or I cannot access the .vdi virtual hard disk from host. After I pass chkdsk or scandisk in the host machine the .vdi size appear as 0 bytes.

comment:30 Changed 6 years ago by frank

  • Guest type changed from other to Windows

comment:31 Changed 6 years ago by frank

  • Component changed from other to shared folders

comment:32 Changed 6 years ago by coonhunter

I have the latest VirtualBox 1.6.2 personal edition running windows xp guest on linux and i can tell you that Microsoft Word cannot open doc files in shared folders.I have the latest guest editions.The issue is not resolved.

comment:33 Changed 6 years ago by coonhunter

..and i have been logging in as administrator and still MS Word cannot open the files in shared folders

comment:34 Changed 6 years ago by dgtlrift

I've set up a shared folder named Vista, and I'm seeing conflicting results when trying to access vboxsvr - when I use explorer, I only see network activity Vista complanes:

"Windows cannot find '\vboxsvr\vista'. Check spelling and try again."

However, if I go into the cmd prompt do a dir listing on the share, I again see the network activity, but after a time I eventually see the share activity and get a listing:

C:\Users\jhanley>dir \vboxsvr\vista
 Volume in drive \vboxsvr\vista is VBOX_vista
 Volume Serial Number is 0000-0801

 Directory of \vboxsvr\vista

08/05/2008  05:17 PM                16 test.cmd
               1 File(s)             16 bytes
               0 Dir(s)  135,153,295,360 bytes free

C:\Users\jhanley>

I'm not sure why I can't get to it from explorer, and if this is pilot error please give me some clue as to where I can correct it.

Host: Linux naboo 2.6.24-19-generic #1 SMP Fri Jul 11 21:01:46 UTC 2008 x86_64 GNU/Linux
Guest: Windows Vista Home Premium
Vbox: Sun xVM VirtualBox 1.6.4
Lan: Host Interface using dynamic tun adapter

comment:35 Changed 6 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use