VirtualBox

Ticket #6470 (closed defect: invalid)

Opened 4 years ago

Last modified 4 years ago

3.1.6 unstable, going back to 3.0.12

Reported by: joy Owned by:
Priority: major Component: other
Version: VirtualBox 3.1.6 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description (last modified by frank) (diff)

Tried 3.1.6 for a while on an AMD64 linux host with SMP 32-bit Windows in a guest:

  1. on a stock 2.6.31 Karmic kernel it's about 10 times slower than on a custom 2.6.32 kernel (just like previous VirtualBox versions)
  2. got BSOD during Windows boot (twice from four trials) - attached logfile
  3. VirtualBox crashed completely during a performance test - attached logfile

as always since 3.1.0 release I am restoring a backup and going back to good old rock stable 3.0.12 release.

Attachments

Crash-3.1.6.log Download (34.8 KB) - added by joy 4 years ago.
BSOD-3.1.6.log Download (50.0 KB) - added by joy 4 years ago.
VBox-3.0.12.log Download (33.7 KB) - added by joy 4 years ago.
VirtualBox 3.0.12 (rock stable) running the same disk image

Change History

Changed 4 years ago by joy

Changed 4 years ago by joy

comment:1 Changed 4 years ago by frank

  • Host type changed from other to Linux
  • Description modified (diff)
  • Guest type changed from other to Windows

comment:2 Changed 4 years ago by frank

Well, for the crash I would appreciate if you could provide me a  core dump. If you can provide one then please contact me via private E-mail at frank _dot_ mehnert _at_ sun _dot_ com so I can tell you an FTP server for uploading the file.

Could you attach a VBox.log file of that guest running with VBox 3.0.12?

Changed 4 years ago by joy

VirtualBox 3.0.12 (rock stable) running the same disk image

comment:3 Changed 4 years ago by joy

3.0.12 log attached. I'll remember to obtain the core dump next time I'll try upgrading (3.1.8?). Thanks.

comment:4 Changed 4 years ago by sandervl73

Not a very useful report, because you don't bother to give us much information.

  1. Duplicate
  2. Probably a duplicate of #5883
  3. If you want it fixed, then we either need a core dump or the name of the 'performance benchmark'. My magic ball isn't working today. :)

comment:5 Changed 4 years ago by frank

Some more investigation: It appears that you enabled 2D support for the 3.1 guest but this function was not yet available yet in VBox 3.0. So the crash and even the BSOD could be related to this function. If you attempt to help then you should retry with VBox 3.1.6, install the 3.1.6 guest additions but this time without the guest 2D acceleration to rule out 2D. 2D/3D may cause crashes due to bugs in VBox but also due to bugs in the host 3D drivers.

comment:6 Changed 4 years ago by joy

I know what you mean, sandervl73. I've given you the logs, though, and have been reporting the performance issues on a Karmic kernel for a long time already. As for the benchmark, it was "Performance Test v6.1" from www.passmark.com. I think it crashed either in one of the 2D or the 3D graphics tests. I did have 2D acceleration enabled in VirtualBox (and 3D disabled). As for if I want it fixed - I care more about the BSOD during bootup since I can easily avoid running the Performance Test but I cannot avoid booting Windows :-)

comment:7 Changed 4 years ago by joy

Frank, I got BSOD before I enabled the 2D test. I agree that the crash was probably related to the acceleration and I admit that I had an older guest additions (3.1.4) installed so feel free to just ignore that crash. I'd be happy if the BSOD went away, though. And I need to try if Ubuntu 10.04 host is faster than 9.10 since that would be a workaround for the Karmic slowness.

comment:8 Changed 4 years ago by joy

I mean enabled 2D acceleration, not 2D test.

comment:9 Changed 4 years ago by frank

What guest Windows is that exactly? XP, Vista or Windows 7?

comment:10 Changed 4 years ago by joy

XP SP3

comment:11 Changed 4 years ago by joy

Guys, I have just got a BSOD during bootup using 3.0.12. That basically means you can close this bug report as invalid because the 3.0.12 is now as stable as the 3.1.6.

comment:12 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to invalid
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use