VirtualBox

Ticket #6468 (closed defect: worksforme)

Opened 4 years ago

Last modified 4 years ago

Cannot Uninstall VirtualBox Network Drivers

Reported by: KeremE Owned by:
Priority: major Component: other
Version: VirtualBox 3.1.6 Keywords: VERR_SUPDRV_COMPONENT_NOT_FOUND, SUN_VBOXNETFLTMP
Cc: Guest type: other
Host type: Windows

Description

Hi,

I was trying o upgrade te latest version. When I've installed the version 3.1.4 from 3.0.4. But after the isntallation I've started to get :

VERR_SUPDRV_COMPONENT_NOT_FOUND

Indicating that the network dirver was not found. I've tried to uninstall VirtualBox manually, reboot and reinstall. But it did not work.

After googling a lot I've noticed that my problem was with:

SUN_VBOXNETFLTMP

registry key. I can not delete it I've tried to delete it manually, or in safe mode. I've tried to take the ownership then delete but non is working. I am not able to run my guests for nearly 2 weeks now.

How can I uninstall this registry key?

Best Regards, Kerem ERSOY.

P.S. - My Latest logs are attached for your reference.

Attachments

VBox.log Download (36.4 KB) - added by KeremE 4 years ago.
Guest Log File
MSI7f3ec.rar Download (38.1 KB) - added by KeremE 4 years ago.
MSI Log RAR
setupapi-logs.rar Download (8.4 KB) - added by KeremE 4 years ago.
setupapi.dev.log and setupapi.app.log realted lines
LNX-TST-CT5-2010-06-01-01-26-45.log Download (50.5 KB) - added by KeremE 4 years ago.
My last log

Change History

Changed 4 years ago by KeremE

Guest Log File

comment:1 Changed 4 years ago by KeremE

Installing 3.1.6 did not change.

BTW my Host is Windows 7 x64 and Guest is CentOS 5.4 but anyway it can never boot becasue it can not find the network.

comment:2 Changed 4 years ago by frank

  • Host type changed from other to Windows

comment:3 Changed 4 years ago by misha

This happens because VBox networking components were not installed properly. Could you create  MSI & setupapi logs for VBox installation process and attach them here.

comment:4 Changed 4 years ago by misha

Please also specify whether/which other third-party networking-related components (i.e. antifiruses, VPN, firewall, other virtualization software, etc.) do you have installed on your host.

Changed 4 years ago by KeremE

MSI Log RAR

Changed 4 years ago by KeremE

setupapi.dev.log and setupapi.app.log realted lines

comment:5 Changed 4 years ago by KeremE

I am using ESET Smart Security 4.0.467.0 (Firewall is in Learn mode so passess pretty everything and isntalls an allow rule) which installs networking drivers (Miniport). I also use Bluetooth. I don't use any VPN software, personal firewall (Other than ESET P/S) and Virtualization software that could effect VBOX. This is the only Virtualization Software I use over my system.

Logs are attached for your reference.

comment:6 Changed 4 years ago by KeremE

Is there anything for followup ? I am not able to use my VBox or nearly a month now :( because of this network issue :(((

comment:7 Changed 4 years ago by misha

According to the logs, there seems to be some generic misconfig with your networking configuration, and also inf cache seems to be corrupted. Both could prevent networking drivers from being properly installed/uninstalled.
I would first try to clear the inf cache for your system, delete %SystemRoot%\inf\INFCACHE.1 and see if it solves the problem.

comment:8 Changed 4 years ago by KeremE

First of all thanks for your response. I've looked for the above mentioned file but I could not find it (I am using Windows 7 x64). Then I've Googled for some time and an saw some information somebody suggested to look under C:\Windows\System32\DriverStore. All I've got in there were: USB and Network drivers for VirtualBox. I've deleted them. Uninstalled and reinstalled 3.2.0 the result was the same. It still cant find the dirves and I got thesame error:

VERR_SUPDRV_COMPONENT_NOT_FOUND

comment:9 Changed 4 years ago by KeremE

Result Code: E_FAIL (0x80004005) Component: Console Interface: IConsole {6375231a-c17c-464b-92cb-ae9e128d71c3}

Changed 4 years ago by KeremE

My last log

comment:10 Changed 4 years ago by KeremE

Hi,

I'm closing this ticket. Finally I've discovered that the problem was not the VirtualBox installation. The problem was there was a corruption in the registry and no application were able to write over it including the windows itself. I've booted from Offline NT & Registry editor and was able to delete the mentioned keys but further installations were not able to recreate these keys. I've reinstalled the system and the problem has gone.

Since the problem was not VirtualBOX installation I've decided to provide this feedback and close the ticket.

Thanks a lot,

KeremE

comment:11 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

Thanks for your feedback!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use