VirtualBox

Ticket #6448 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

512MB guest use 1.5g memory

Reported by: raveman Owned by:
Priority: major Component: other
Version: VirtualBox 3.1.6 Keywords: memory
Cc: Guest type: Windows
Host type: Linux

Description (last modified by frank) (diff)

All guests are started with 512Mb 2-3weeks later 2-3 guests use more memory (not the same 2-3 randomly changing which is).

14145 x1 20   0  945m 755m  56m S    3  6.3   1875:37 VBoxHeadless
 4799 x2 20   0  896m 618m  50m S    3  5.1   1847:28 VBoxHeadless
 5047 x3 20   0  900m 627m  53m S    2  5.2   2543:18 VBoxHeadless
 8440 x4 20   0  885m 632m  56m S    2  5.2 205:35.68 VBoxHeadless
 9780 x5 20   0  890m 642m  56m S    2  5.3 186:16.06 VBoxHeadless
14496 x6 20   0 1268m 1.0g  56m S    2  8.6   2131:06 VBoxHeadless
 7980 x7 20   0  892m 671m  56m S    2  5.6 197:35.76 VBoxHeadless
 2193 x8 20   0  973m 727m  53m S    1  6.0 866:16.88 VBoxHeadless
14557 x9 20   0 1460m 1.2g  56m S    1 10.1 808:48.26 VBoxHeadless
27842 x10 20   0  893m 622m  56m S    1  5.2 402:09.96 VBoxHeadless
 9533 x11 20   0  986m 734m  56m S    1  6.1 160:08.03 VBoxHeadless

1 week later this numbers are going higher... this very nice when the host need to use swap then host have minutes to crash because swap not fast as mem. This is an old bug, but still live on 3.1.6 and latest GA installed on XP.

Attachments

VBox.log Download (228.5 KB) - added by raveman 4 years ago.

Change History

comment:1 Changed 4 years ago by frank

  • Description modified (diff)

VBox.log of such a guest please.

Changed 4 years ago by raveman

comment:2 Changed 4 years ago by frank

I see a log of RDP authentication cycles within that log. Wild guess: Could it be that the memory usage increases each time you connect to the VM? That is, could you test to do 10 such authentication cycles and then compare the memory usage of the VM before these authentication cycles?

comment:3 Changed 4 years ago by raveman

i did 15 ,not affect any memory changes.I did a big file copy from ftp i open 20 webbrowser but nothing.

comment:4 Changed 4 years ago by raveman

Anything around videomemory?

comment:5 Changed 4 years ago by frank

No, shouldn't be a problem. Still no idea why your VM RAM usage increases. Any chance to change the VM from NAT to bridged mode and let it running for a longer time?

comment:6 Changed 4 years ago by wschan

I have the same problem on both Linux and Solaris hosts (Windows and Linux guests). The symptom can be reproduced like this: Connect to the console of the guest using RDP. Run a web browser on the guest and go to some site that displays some Flash animation or video. I can see the memory usage of the VM growing bigger and bigger. Once the RDP connection terminates, the memory increase will stop, even if the browser is still running. When I reconnect using RDP, the memory usage starts to increase again.

Another way to reproduce the symptom is doing a Windows 7 guest installation using RDP connection to the guest console (VBoxHeadless) right at the start. After DVD installation, guest addition and Windows updates, the memory usage of a 2G VM can grow to 3.5G!

I have tried versions 3.0.8, 3.0.14, 3.1.6, 3.1.8 and 3.2.0. All have the same memory leak problem. It only affects Linux and Solaris. Windows hosts seems to be immune.

comment:7 Changed 4 years ago by patrickc

What you've added in that last comment seems to match what I've seen and added to #5966 (mem leak while rdp connection active and screen changing) - I've seen the leakage with a winxp host.

comment:8 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 3.2.12.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use