VirtualBox

Ticket #642 (closed defect: fixed)

Opened 7 years ago

Last modified 4 years ago

100% CPU utilization with two or more VM.

Reported by: agent_p2 Owned by:
Priority: major Component: other
Version: VirtualBox 1.5.0 Keywords: knoppix linux winXP CPU utilization
Cc: Guest type: other
Host type: other

Description

Host OS: WindowsXP. Guest OS: KNOPPIX_V5.1.1CD-2007-01-04-EN

Problem: When Im trying to run two or more KNOPPIX_V5.1.1CD-2007-01-04-EN(console only) on VirtualBox 1.5.0 Im getting 100% CPU utilization and computer is almost freezing. This problem doesn`t occure on 1.4.0. I`ve had to downgrade back to 1.4.0.

Change History

comment:1 Changed 7 years ago by agent_p2

1

comment:2 Changed 7 years ago by raxyx

I can confirm the problem.

Host: Debian Etch, amd64 version, X and KDE, up2date (kernel 2.6.18-5)

Guests: Debian 32bit, mostly etch, some partially lenny; (console only, no X)

I'm running VirtualBox 1.5.0 from the repositories. Any standard VM takes about 30-40 % CPU (in idle state), so running 1 is possible, but 3 or more will completely block the CPU; the same VMs perfectly worked in 1.4.0

comment:3 Changed 7 years ago by jk

I also confirm the problem.

Host: Debian Etch Guests: WindowsXP, Debian Etch

The high CPU utilization happends only for the Linux guests. XP is taking no more then 10% when idle.

Downgrading to 1.4 helped...

comment:4 Changed 7 years ago by plug

Don't know if this is related, but running linux guest (centos) on XP host, I sometimes experience 100% of one core usage even when linux is fully Idle. This does not happen all the times, sometimes I launch the LinuxGuest and it does not burn my cpu, sometimes it does. I haven't been able to tell what triggers this. Exact same symptoms on one of my friends PC. Downgrading from 1.5.0 to 1.4.0 solves this (but I loose working clipboard). BTW, I use a re-compiled Centos kernel running at 100Hz instead of 1000Hz to lower cpu usage.

comment:5 Changed 6 years ago by xargos

The bug is still present in v1.5.6. It's _really_ hard to use virtual network because of this bug.

host: Kubuntu Gutsy (7.10)

guest1: Debian Etch (console only) guest2: Debian Etch (console only)

comment:6 Changed 6 years ago by xargos

It seems the bug has been finally solved :) I'm using new Kubuntu Hardy 8.04 with default kernel (2.6.24) and new VirtualBox (1.6.0 closed source) as host and use the same guests with the same configuration as mentioned in the last report.

comment:7 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use