VirtualBox

Ticket #6394 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Win7 x64 host crashes on WinXP x86 guest startup

Reported by: StefanP Owned by:
Priority: blocker Component: other
Version: VirtualBox 3.1.4 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

I recently moved from Vista x86 to Win7 x64 as my main system.

I do have two guest systems, Win7 x64 and WinXP x86 SP3.

There are no problems with the Win7 guest, but starting the WinXP guest, the host system crashes to a BSOD.

I have deleted the WinXP guest and wanted to recreate it, but this does not work either.

Both guest were running without problems on the same hardware with Vista x86 SP2.

Attached find the log and mini dump.

Thanks in advance, Stefan

Attachments

VBox.log Download (35.4 KB) - added by StefanP 4 years ago.
Virtual Box Log of new installation attempt
031710-278524-01.dmp Download (353.6 KB) - added by StefanP 4 years ago.
BSOD Mini Dump
STOP Error.png Download (15.0 KB) - added by StefanP 4 years ago.
STOP error after disabling USB support
VBox.log.1 Download (49.7 KB) - added by StefanP 4 years ago.
Virtual Box Log after disabling USB
VBox.2.log Download (50.2 KB) - added by StefanP 4 years ago.
Virtual Box Log after disabling AMD-V in addition
Guest Config.png Download (66.9 KB) - added by StefanP 4 years ago.
guest configuration
VBox.3.log Download (59.5 KB) - added by StefanP 4 years ago.
Virtual Box Log of working Win7 VM

Change History

Changed 4 years ago by StefanP

Virtual Box Log of new installation attempt

Changed 4 years ago by StefanP

BSOD Mini Dump

comment:1 Changed 4 years ago by sandervl73

Strange. Could you disable the USB controller in the VM and try again? Another thing to try is to turn off AMD-V support in the VM settings.

If you get the same crash without the USB controller and turning off AMD-V helps, then try to see if there's a BIOS update for your machine.

comment:2 Changed 4 years ago by StefanP

Thanks for the suggestions, but they do not help.

I have already updated the BIOS to the latest version due to the problems with the VM.

I have disabled USB entirely and was able to start the VM, but got a ntdll STOP error. Disabling AMD-V does not help either.

Find more logs and some images attached.

--- Stefan

Changed 4 years ago by StefanP

STOP error after disabling USB support

Changed 4 years ago by StefanP

Virtual Box Log after disabling USB

Changed 4 years ago by StefanP

Virtual Box Log after disabling AMD-V in addition

Changed 4 years ago by StefanP

guest configuration

comment:3 Changed 4 years ago by sandervl73

Could you also attach the VBox.log of the successful Windows 7 VM?

comment:4 Changed 4 years ago by sandervl73

You are not running an XP compatibility mode session at the same time I assume? (shouldn't matter when you turn off AMD-V though)

comment:5 Changed 4 years ago by StefanP

No, I am not running anything in any compatibility mode, I have never had any need to do this.

Attached find the log of the working Win7 guest.

--- Stefan

Changed 4 years ago by StefanP

Virtual Box Log of working Win7 VM

comment:6 Changed 4 years ago by StefanP

I was now able to do a fresh install of the WinXP x86 guest using a new installation media, the old one got corrupted.

I am now running VirtualBox 3.1.6 with only USB support being disabled. I will report back, if USB support can be enabled.

comment:7 Changed 4 years ago by StefanP

With v3.1.6 there is no more crash when USB is enabled, including USB 2.0 support.

comment:8 Changed 4 years ago by sandervl73

So we can conclude the problem is fixed?

comment:9 Changed 4 years ago by StefanP

Sorry for not mentioning that the issue is resolved.

You can close this issue now.

comment:10 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Ok, thanks for the feedback.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use