VirtualBox

Ticket #6379 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

VBoxManage crashes when saving state in the headless mode => Fixed in SVN/3.1.6

Reported by: decke Owned by:
Priority: major Component: VM control
Version: VirtualBox 3.1.4 Keywords: vboxheadless savestate
Cc: Guest type: other
Host type: Linux

Description

This Bug was reported by Alexander Zagrebin during a FreeBSD call for testers and only forwarded by me. This happened on FreeBSD with VirtualBox 3.1.4 and i could also reproduce that on Linux with VirtualBox 3.1.4.

Try these commands to reproduce the bug:

$ VBoxHeadless -s Test &
$ VBoxManage controlvm Test savestate
Sun VirtualBox Command Line Management Interface Version 3.1.4_OSE
(C) 2005-2010 Sun Microsystems, Inc.
All rights reserved.

0%...10%...20%...
Error: failed to save machine state. No error message available!

The reason is an arithmetic exception (division by zero) in the displayMakeThumbnail (src/VBox/Main/DisplayImpl.cpp, line 161) due to cx and cy are set to 0.

cxThumbnail = (kMaxSizeThumbnail * cx) / cy;

One possible solution would be to not generate the thumbnail. Patches for this are attached.

Attachments

patch-no-thumbnails.diff Download (1.5 KB) - added by decke 4 years ago.
Patch to not generate a thumbnail. Author: Alexander Zagrebin <alexz AT visp.ru>

Change History

Changed 4 years ago by decke

Patch to not generate a thumbnail. Author: Alexander Zagrebin <alexz AT visp.ru>

comment:1 Changed 4 years ago by decke

To be clear VBoxHeadless so the VM crashes and not VBoxManage.

comment:2 Changed 4 years ago by frank

  • Summary changed from VBoxManage crashes when saving state in the headless mode to VBoxManage crashes when saving state in the headless mode => Fixed in SVN/3.1.6

We think we fixed this problem properly. The upcoming maintenance release will contain the fix.

comment:3 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in 3.1.6.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use