VirtualBox

Ticket #6369 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

Going Crazy Trying To Get Windows 2000 Pro Installed As Client, And Now VBOX Crashes

Reported by: oldefoxx Owned by:
Priority: major Component: other
Version: VirtualBox 3.1.4 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

I am running the latesxt Sun VirtualBox on top of Ubuntu 9.04, and having all sorts of strange behavior. For instance, I do not have a good way to change which ISO images are available for the CD-ROM drive. That use to be an easy choice through Devices, but that has changed. I also have to shut down the client in order to designate if the CD-ROM is available or passthrough at the VirtualBox control level. I also noted that I can designate a second VDI to use with a given client, but have no details on how that should work. I don't see that a link to that second VDI appears on the client's side. VirtualBox also assumes that there is a floppy drive, though many newer PCs lack one. And he CD-ROM drive has to be added under the Settings before it appears, though it is the most likely peripheral with most PCs. As to sound, the client can get it, but the volume setting is about half that as obtainable under Ubuntu.

I can install Windows 2000 Pro, but in many cases it cannot boot. It gets a Blue Screen of Death and some obscure error message. Sometimes it reports INACCESSABLE_BOOT_DEVICE, sometimes KMODE_EXCEPTION_NOT_HANDLED, and sometimes something else. Best I can determine it relates to a problem with a driver or with a device. Sometimes it just hangs, and a Safe Boot shows that it stopped past the install of mup.sys, which according to some web reports, means it ran into a real problem with plug 'n play. That was never a problem with setting up Windows 2000 Pro until the last month or so, when new versions of VirtualBox came out.

One web site suggested running CHKDSK from the Remote Console for Windows and see if any problems showed up from the formatting of the virtual hard drive. I did that, and decided to make the virtual hard drive large enough to hold three FAT32 partitions from a backup of an older PC, each partiton being only about 30 GB. I used Acronis' True Image version 11 for this, and as far as I could tell, it seems to have made the restore, but it had to give two of the partitions different letters because the CD-ROM drive is fixed as Drive D. It also took about ten times longer than I would have expected, but I put that down to the efforts to expand the dynamically allocated drive space, to possibly move Ubuntu's folders and files for a consecutively sectored virtual drive, and having to convert the file structure from 16 kb clusters to 32 kbit clusters (slight increase in allocated partition space from old to new). I did not know if VirtualBox would allow restoring multiple partitions, but so far as I can tell, it may have done so. But none of the restored Windows 2000 partitions will run the boot process to completion, each hanging after safe mode shows mup.sys got loaded. So I decided to use CHKDSK as suggested, and it ran to completion on what Remote Console reports are drives D: and E;

But it crashed with I tried it on Drive C:, and wanted me to send you the logs and pmg that related to it, and tell you what it was that I was trying to do.

I was very pleased and happy with what VirtualBox was, but the last four weeks of trying to use the latest and greatest have been extremely disappointing. I never suspected it might be a problem within VirtualBox itself, but all efforts to get either Windows 2000 Pro or XP up and running with the latest version of VirtualBox have been extremely disappointing. Had these efforts been made on one of the PCs I've had great success with already. Instead, I was doing it on a new PC that I had just gotten, and somehow I thought these problems might be related t the PC hardware, not to the host and VM setup.

Attachments

VBOXCrash.odt Download (95.2 KB) - added by oldefoxx 4 years ago.

Change History

Changed 4 years ago by oldefoxx

comment:1 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

duplicate of #6368.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use