VirtualBox

Ticket #6367 (closed defect: duplicate)

Opened 4 years ago

Last modified 3 years ago

VBoxManage clonehd requires fill path names for source and destination files

Reported by: scottderrick Owned by:
Priority: major Component: other
Version: VirtualBox 3.0.12 Keywords: VBoxManage clonehd
Cc: Guest type: Windows
Host type: Linux

Description

Here is an example using relative paths. The two .vdi files are in the current directory

scott@scotts-laptop:~/.VirtualBox/VDI$ /usr/lib/virtualbox/VBoxManage clonehd --existing Vista.vdi Vista2.vdi VirtualBox Command Line Management Interface Version 3.0.12 (C) 2005-2009 Sun Microsystems, Inc. All rights reserved.

ERROR: Cannot register the hard disk '/home/scott/.VirtualBox/VDI/Vista.vdi' with UUID {00eca137-b49e-4bfe-1388-ae5a2a4b7974} because a hard disk '/home/scott/.VirtualBox/VDI/Vista.vdi' with UUID {00eca137-b49e-4bfe-1388-ae5a2a4b7974} already exists in the media registry ('/home/scott/.VirtualBox/VirtualBox.xml') Details: code NS_ERROR_INVALID_ARG (0x80070057), component VirtualBox, interface IVirtualBox, callee nsISupports Context: "OpenHardDisk(Bstr(szFilenameAbs), AccessMode_ReadWrite, false, Bstr(""), false, Bstr(""), srcDisk.asOutParam())" at line 624 of file VBoxManageDisk.cpp

Here is the output using full pathnames

scott@scotts-laptop:~/.VirtualBox/VDI$ /usr/lib/virtualbox/VBoxManage clonehd --existing /home/scott/.VirtualBox/VDI/Vista.vdi /home/scott/.VirtualBox/VDI/Vista2.vdi VirtualBox Command Line Management Interface Version 3.0.12 (C) 2005-2009 Sun Microsystems, Inc. All rights reserved.

0%...10%...20%...30%...40%...50%...60%...

it was still running when I took this snap shot.

Change History

comment:1 Changed 4 years ago by whit

Problem apparently persists in 3.2.6 - haven't tested if full paths fixes.

# VBoxManage clonevdi 10.04_Alpha_1.vdi Ubuntu_10.04.vdi Oracle VM VirtualBox Command Line Management Interface Version 3.2.6 (C) 2005-2010 Oracle Corporation All rights reserved.

ERROR: Cannot register the hard disk '/root/.VirtualBox/10.04_Alpha_1.vdi' with UUID {21ff8b5c-b66d-4ce8-9f6b-252c2bde777e} because a hard disk '/root/.VirtualBox/10.04_Alpha_1.vdi' with UUID {21ff8b5c-b66d-4ce8-9f6b-252c2bde777e} already exists in the media registry ('/root/.VirtualBox/VirtualBox.xml') Details: code NS_ERROR_INVALID_ARG (0x80070057), component VirtualBox, interface IVirtualBox, callee nsISupports Context: "OpenHardDisk(Bstr(szFilenameAbs), AccessMode_ReadWrite, false, Bstr(""), false, Bstr(""), srcDisk.asOutParam())" at line 630 of file VBoxManageDisk.cpp

comment:2 Changed 4 years ago by whit

Yup, full path fixes...

# VBoxManage clonevdi /root/.VirtualBox/10.04_Alpha_1.vdi /root/.VirtualBox/Ubuntu_10.04.vdi Oracle VM VirtualBox Command Line Management Interface Version 3.2.6 (C) 2005-2010 Oracle Corporation All rights reserved.

0%...

comment:3 Changed 4 years ago by klaus

  • Status changed from new to closed
  • Resolution set to duplicate

duplicate of #3553

comment:4 Changed 3 years ago by ibboard

Why was this closed against #3553? That seems like a different problem (not killing versus requiring absolute paths) and the bug still exists in the latest pre-releases of v4.

comment:5 Changed 3 years ago by klaus

Sorry, that was the wrong ticket... the earliest report of this issue is #3888.

It will be fixed with 4.0.0.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use