VirtualBox

Ticket #6366 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

certain network events not detected by vbox?

Reported by: bughunter2 Owned by:
Priority: major Component: network/NAT
Version: VirtualBox 3.1.4 Keywords: network tcp
Cc: Guest type: Windows
Host type: other

Description

Description of the problem:

When connecting to a webserver which supports HTTP keep-alive using a browser which also supports this, it may occur (at least, on Windows XP guests) that after the webserver closes the socket (because the HTTP keep-alive timeout expired), the socket stays in the TCP ESTABLISHED state on the (Windows XP) guest, which I observed using netstat.

After a period, however, the connection is completely dropped (it doesn't get to the CLOSE_WAIT state). I ran a batch script which constantly called 'netstat -an | findstr IP', without any delay in between the calls, so I'm pretty sure this is indeed what happened.

When testing this on the host (i.e., outside of VirtualBox), the issue doesn't occur.

How to reproduce:

  1. Open a TCP connection from the guest to the host.
  2. Send some data from the guest to the host.
  3. Send some data from the host to the guest.
  4. Leave it opened for *at least* ~10 milliseconds.
  5. On the host, close the TCP connection by calling closesocket().

(Step 2 and 3 are probably irrelevant, didn't check.)

I've observed that the issue disappears when leaving out step 4 (i.e., when immediately closing the connection after sending data from the host to the guest).

With Linux guests, the issue doesn't seem to occur. Therefore, it seems likely that the issue is specific to Windows guests (I've only tested XP however).

Attachments

XP-2010-03-16-15-55-56.log Download (55.2 KB) - added by bughunter2 4 years ago.

Change History

comment:1 Changed 4 years ago by frank

A VBox.log file of such a VM session is missing. This file will tell us the configuration you are using.

Changed 4 years ago by bughunter2

comment:2 follow-up: ↓ 3 Changed 4 years ago by bughunter2

There you go. :)

comment:3 in reply to: ↑ 2 Changed 4 years ago by Hachiman

  • Component changed from other to network/NAT

Replying to bughunter2:

There you go. :)

Could you please, share your test application?

comment:4 Changed 4 years ago by Hachiman

Does it still happens with 3.1.6?

comment:5 Changed 4 years ago by bughunter2

It doesn't happen with 3.1.6.

comment:6 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use