VirtualBox

Ticket #6332 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

Linux Guest suffers from disk I/O errors

Reported by: Flancer Owned by:
Priority: major Component: guest smp
Version: VirtualBox 3.1.4 Keywords:
Cc: Guest type: other
Host type: Linux

Description

This only happens when we are using Virtual Box 3.0 and above.

The Guest machine is loaded with Ubuntu Server 8.0.4 and Zimbra 5 and 6.

Reverting to VirtualBox 2.2.4 would remove the problem

Attachments

VBox.log Download (46.2 KB) - added by Flancer 4 years ago.

Change History

Changed 4 years ago by Flancer

comment:1 Changed 4 years ago by Flancer

Sorry I think I need to make a correction. This was first observed in VirtualBox 3.1.2 and persisted in 3.1.4 . The frequency is random; sometimes it happens within 24 hours and sometimes after 2 or 3 days.

comment:2 Changed 4 years ago by Flancer

Oops just realised I forgot to specify host type.

Host type is also Ubuntu Server.

The behaviour has been observed in both 64bit and 32bit hosts.

The controller used for the Guests are the Intel AHCI controller.

comment:3 Changed 4 years ago by sandervl73

Well, 2.x doesn't support guest SMP. Your log shows 2 VCPUs. Does it also happen with 1 CPU? Could you be more specific about the type of disk errors?

comment:4 Changed 4 years ago by sandervl73

  • Host type changed from other to Linux

comment:5 Changed 4 years ago by Flancer

The CPU used in both of the cases discovered were dual core (AMD X2) and triple core (AMD X3)CPUs .

We couldn't capture the disk errors as reported by the Guest from the dmesg as we had to immediately reboot the Guest.

I believe you will notice that the VBox.log shows disks errors as well?

Sometimes rebooting the Guest did not work as the filesystem seems to have been corrupted (fsck didn't help either... ). In this case we only manage to recover by restoring from a snapshot.

comment:6 Changed 4 years ago by Flancer

By the way, Ubuntu 8.0.4 Guests that did not have Zimbra installed worked fine.

comment:7 Changed 4 years ago by sandervl73

I'm talking about the number of cpus in the guest of course. Does it happen with 1 virtual CPU?

comment:8 Changed 4 years ago by Flancer

Have yet to test with that setting. Will confirm sometime on Monday.

comment:9 Changed 4 years ago by Flancer

Ok, been looking at the Guest since we changed the CPU from 2 to 1 yesterday. The Guest has been up for 1 day 6 hours without incidence. Will check again the following day.

comment:10 Changed 4 years ago by Flancer

Still no crashes yet.

Could you elaborate on how changing the number of CPUs have helped the situation? Is this a bug or an expected behaviour?

Thank you.

comment:11 Changed 4 years ago by sandervl73

  • Component changed from other to guest smp

It's a bug of course. Reducing the nr of cpus to zero was just a way to isolate the problem. Thanks for the feedback.

comment:12 Changed 4 years ago by Flancer

Any updates on this bug? I dare not upgrade any production machines until there is some kind of a confirmation it has been fixed.

comment:13 Changed 4 years ago by sandervl73

Please update to 3.2.10 and retry. There have been quite a few SMP fixes since 3.1.4. We won't know if your problem is gone until you actually try it.

comment:14 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use