VirtualBox

Ticket #6303 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

Can't attach USB Device

Reported by: sandrich Owned by:
Priority: major Component: USB
Version: VirtualBox 3.1.4 Keywords:
Cc: Guest type: Windows
Host type: Mac OS X

Description

I get following error when Trying to enable this USB Device. In the Dropdown menu it shows

Westmountain Radio Computerized Battery Analyzer / [0310]

After clicking on it nothing happens. After clicking the second time I get this error. Tried to restart and plugin / out but it did not work.

I am using

Virtualbox 3.1.4 Mac is the Host Windows 7 or XP the Guest. Doesn't work on both.

Failed to attach the USB device West Mountain Radio Computerized Battery Analyzer / [0310] to the virtual machine Windows 7. USB device 'West Mountain Radio West Mountain Radio Computerized Battery Analyzer /' with UUID {c8125b3b-e2a0-4c5e-b85d-10cb3918f3b0} is busy with a previous request. Please try again later.

Result Code: NS_ERROR_INVALID_ARG (0x80070057) Component: HostUSBDevice Interface: IHostUSBDevice {173b4b44-d268-4334-a00d-b6521c9a740a} Callee: IConsole {6375231a-c17c-464b-92cb-ae9e128d71c3}

Change History

comment:1 follow-up: ↓ 3 Changed 4 years ago by os2mac

I am also seeing the same thing. Doesn't matter which guest, or device if I attach I USB device to the host machine I cannot take control of it through the guest OS. this worked in previous editions of Virtual Box.

comment:2 Changed 4 years ago by wawiggs

Having the same issue with connecting a common access card (CAC) reader device. Device worked in previous editions of VirtualBox.

comment:3 in reply to: ↑ 1 Changed 4 years ago by os2mac

Replying to os2mac:

I am also seeing the same thing. Doesn't matter which guest, or device if I attach I USB device to the host machine I cannot take control of it through the guest OS. this worked in previous editions of Virtual Box.

reinstalled 3.1.2 and this corrected it's definately something in the new update. and it's not just card readers it's any USB device

comment:4 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #6251

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use