VirtualBox

Ticket #6302 (new defect)

Opened 5 years ago

Last modified 4 months ago

Installing VBox with bridging adapter kills host's physical interface's TCP/IP functionality

Reported by: Neighbour Owned by:
Priority: blocker Component: network/hostif
Version: VirtualBox 3.1.4 Keywords:
Cc: Guest type: other
Host type: Windows

Description

Apparently something changed between 3.1.0 and 3.1.4 (skipped 3.1.2). Bridging is now done as a NIC component/protocol instead of an additional driver for each NIC. Unfortunately, after installing, TCP/IP of the host (one physical adapter) stops working.
The NIC doesn't list under ipconfig, trying to repair the interface by using windows' repair functionality informs me that TCP/IP is not enabled (which it is). Uninstalling virtualbox and rebooting restores TCP/IP functionality.

Change History

comment:1 Changed 5 years ago by Neighbour

Oops, forgot to mention. The host is running windows xp x64 SP2. The physical NIC is an Intel Pro/1000MT (pci-e).

comment:2 Changed 5 years ago by frank

  • Component changed from network to network/hostif

comment:3 Changed 5 years ago by misha

There were no significant changes done for bridging between 3.1.0 and 3.1.4.
This seems like a conflict with some other networking component.
Could you specify what custom networking0rekated components do you have installed on your host (i.e. antivirus, firewall, virtualization, VPN software, etc.)?

comment:4 Changed 5 years ago by Neighbour

The only custom component I have installed is Hamachi. I had openVPN installed as well when I still worked with 3.1.0, but I uninstalled that before installing virtualbox 3.1.4

comment:5 Changed 5 years ago by Neighbour

To be more precise, the Hamachi driver is version 6.0.2.2 (Hamachi client version 1.0.3.0) It has been installed since before I started using virtualbox, so I'm inclined to think that's not the cause of the problem.

comment:6 Changed 5 years ago by Neighbour

D'oh...I made a bit of a mistake regarding the previous version I've been running. Just took a look at the last vbox.log, and apparently I've been using 3.0.8 r53138 before trying 3.1.4. So maybe something changed between those versions. Sorry for the confusion.

comment:7 Changed 5 years ago by galmok

I experience something quite similar, except the virtualbox installer locks up trying to install the network drivers. I checked the device manager and my physical network adapters were cloned and had the virtualbox miniport driver string attached. Also, I had the 'Virtualbox Host-Only Ethernet Adapter' device present. While the installer was hanging, I couldn't access the network. I ended up uninstalling all virtualbox miniport drivers manually and then the virtualbox installer finished normally.

But even after uninstalling all of Virtualbox, I haven't regained network access on my ethernet. Only my wireless works. :-(

I hope a reboot fixes this...

It seems the miniport drivers conflict with something on my system.

I am using Vista64.

comment:8 Changed 5 years ago by galmok

Well, a reboot didn't solve it. I am stumped as to how to regain control of my ethernet link again. I can see that windows can detect if I have plugged the cable in or not and I can see that it tries to send data, but there are no packages coming in.

I even tried reinstalling the ethernet driver, but that also didn't help.

Virtualbox really screwed my system up good. :-(

Any ideas? Short of reinstalling windows, preferably.

comment:9 Changed 5 years ago by galmok

Just to let you know that I finally have my ethernet back. I am not sure where the fault was, but I am sure Virtualbox network drivers were at fault for most of my issues.

comment:10 Changed 5 years ago by frank

Well, if you are sure that this is the fault of VirtualBox, what did you change to make it work?

comment:11 Changed 5 years ago by galmok

I didn't make it work. I have temporarily given up upon Virtualbox and have uninstalled it. My next attempt will be to install it, but clicking no to installing the network drivers. I hope this will work.

I just can't be without ethernet at this moment which is why I have to stop experimenting.

comment:12 Changed 5 years ago by Neighbour

Fortunately, this issue does not happen in 3.1.6

comment:13 follow-up: ↓ 14 Changed 5 years ago by galmok

I have retried the VirtualBox installation, but now with v3.1.8 and now the installation went without any problems. Checking the device manager I see only 1 VirtualBox device in the Network section: VirtualBox Host-Only Ethernet Adapter.

The VirtualBox miniport drivers do not seem to be installed per default (didn't change installation defaults) and it may have been those that cause my earlier grief.

3-4 drivers did get installed, but I can only find the above mentioned driver in the device manager list.

comment:14 in reply to: ↑ 13 ; follow-up: ↓ 16 Changed 5 years ago by misha

Replying to galmok: This is ok to see only one Host-Only Ethernet Adapter in dev manager after VBox install. The bridging driver should be visible only in the properties dialog for your host ethernet connections.

To all having this issue: please try the latest 3.2.10 release and let me know if the issue still present there.

comment:15 Changed 3 years ago by Urmas

I started to have this issue after 4.0.8 -> 4.1.18 upgrade.

comment:16 in reply to: ↑ 14 Changed 3 years ago by Darwood

Replying to misha:

Replying to galmok: This is ok to see only one Host-Only Ethernet Adapter in dev manager after VBox install. The bridging driver should be visible only in the properties dialog for your host ethernet connections.

To all having this issue: please try the latest 3.2.10 release and let me know if the issue still present there.

I'm still getting this problem with 4.1.22 r80657

PC: Acer AcerPower M6

OS: Windows XP Pro SP3

NIC: NVIDIA nForce 10/100/1000 Mbps Ethernet (integrated on mainboard)

I can only get around this by choosing not to install the Bridged Networking components during install. If I forget to do this I have to perform a Windows System Restore to get networking on the host to work again.

Once VB has installed then if any Guest with a network interface enabled is Started then the Guest and/or Host intermittently lose network connection.

comment:17 Changed 2 years ago by pop1989_bb

I'm still getting this problem with 4.2.16 r86992. Without the Bridge I can use VB & the VMs with network-support.

comment:18 Changed 22 months ago by alecalixto

Same happens here, with .16 version over Win8 host, didn't happen with .12

Host without Internet connection at all, fixed only with VB's uninstall :-(

comment:19 Changed 7 months ago by FoxJr

I currently have virtual box 4.3.16 r95972 installed and everything works fine. When I try to upgrade virtual box 4.3.18 or 4.3.20 my PC network card becomes messed up and the whole system becomes unstable. Any suggestions? Below plz find PC specifications for your reference;

CPU: 3.07 gigahertz Intel Core i3 540 RAM: 8GB DDR3 HD: WD 500GB Network Card: Realtek PCIe GBE Family Controller Motherboard: ASUSTeK Computer INC. P7P55 LX Rev X.0x OS: Windows 8.1 Professional (Upgraded from Windows 8 Professional)

Thanks in advance.

Last edited 7 months ago by FoxJr (previous) (diff)

comment:20 Changed 6 months ago by FoxJr

Managed to fix my issue by uninstalling virtualbox, installing it without host-only bridge adaptor and installing this manually as a legacy network adaptor via device manager. Kindly note that my Windows 8.1 was upgraded from Windows 8, it seems that this is an issue of some sort as I have read a lot about ppl having the same problem within the same scenario.

comment:21 Changed 5 months ago by evit

I'm having the same problem with VirtualBox 4.3.22 for Windows on Windows 7 Pro 64 Bit patched as of today. After virtual box install it disabled eth0 (first NIC) and I have no networking at all. I had to log in as Admin and disable and reenable both interfaces for it to sort of work. Not it keeps putting the card off line and online. Not sure how this bug reared its ugly head so often but it has.

comment:22 Changed 5 months ago by VVP

Hello Evit, is it regular problem or not? Do you see this issue every time or it had happened only once? would you provide installation log?

comment:23 Changed 5 months ago by VVP

I uploaded 4.3 release for testing. Try it. I'll expect feedback with some results. please, don't forget to upload installation log too. https://www.virtualbox.org/download/testcase/VirtualBox-4.3.23-98273-Win.exe .

comment:24 Changed 4 months ago by EggyBird

I have the same issue after installing 4.3.22. Tried VVP's version 4.3.23 but issue remains the same. De-installing brings connectivity back. Where can I find the installation log file on the file system?

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use