VirtualBox

Ticket #6299 (closed defect: fixed)

Opened 4 years ago

Last modified 7 months ago

Vbox causes BSOD on host system when run second time

Reported by: DoctorBrown Owned by:
Priority: major Component: other
Version: VirtualBox 3.1.4 Keywords:
Cc: Guest type: other
Host type: Windows

Description (last modified by frank) (diff)

I'm running Win 7 Pro x64. Running VBox 3.1.4. The problem I'm having is that VBox causes a BSOD when I run it a second time.

I installed VBox and it was running fine when I was logged in as the administrator. In order to also run it as a normal user and use the same VMs, I moved the .VirtualBox directory and all VMs to another drive. Now I can run it either as the user or admin only once. If I exit VB and restart it my system crashes. Before, I moved the .VirtualBox folder I could not run VBox as the normal user. I would get a BSOD as soon as I ran VBox.

So that both the admin and user could access the same VMs, I moved everything to E:\.VirtualBox using the following steps:

  1. As admin, I moved the HardDisks directory and changed the default hard disk folder to E:\.VirtualBox\HardDisks
  2. Changed the default machine folder to: E:\.VirtualBox\Machines
  3. Recreated all VMs using disk images stored in above hd folder.
  4. Moved .virtualbox.xml to E:\.VirtualBox
  5. Added system variable: VBOX_USER_HOME=E:\.VirtualBox
  6. Rebooted system.

Now I can run VBox from either the admin or normal user but only once. If I launch it again my system crashes. Any ideas how to fix this? Is there something I missed in my process of moving the .VirtualBox folder? Is there a different way to setup VBox to be able to run as either the admin and normal user?

I have attached the minidump file. I have not attached a VBox.log because the BSOD occurs before I launch any VMs.

Attachments

022610-34304-01.dmp Download (355.3 KB) - added by DoctorBrown 4 years ago.
Windows 7 minidump file

Change History

Changed 4 years ago by DoctorBrown

Windows 7 minidump file

comment:1 Changed 4 years ago by DoctorBrown

I was wondering if anyone has been able to look at this, maybe let me know if it's a know issue or not. Or if there is a workaround I could try in the mean time. Thanks, DoctorBrown

comment:2 Changed 7 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)

Please reopen if still relevant with VBox 4.2.16.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use