VirtualBox

Ticket #6280 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

XP guest becomes unreachable on vboxnet0 after a couple of hours

Reported by: hansb Owned by:
Priority: blocker Component: network/hostif
Version: VirtualBox 3.1.4 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

The XP guest on the Ubuntu Karmic x64 host works flawlessly for a while, communicating with the host on the host-only network.

After a couple of hours the ip of the guest becomes unreachable (that's what ping reports if pinged from the host side).

Guest still runs happily and also appears to see the host ip (wrote a little script pinging the host once in a while and restarting if host gone, the script apparently still sees the host).

But the host can't see the guest IP any more.

Powering down and restarting the guest vm means it'll work again for a while, until the guest IP disappears again after a couple of hours, etc.pp.

This is an upgraded system from VB 3.1.2.

Attachments

VBox.log Download (62.2 KB) - added by hansb 4 years ago.
VBox.2.log Download (39.5 KB) - added by hansb 4 years ago.

Change History

Changed 4 years ago by hansb

comment:1 Changed 4 years ago by v-pluk

Experiencing the same problem. I can reproduce this when starting a 8 threaded download within the guest (WinXP SP3). It is not predictable when it will exactly will happen, but most of the time within half an hour.

I'm not sure if the host was generating traffic too.

Ubuntu Karmic Linux hostname 2.6.31-20-generic #57-Ubuntu SMP Mon Feb 8 09:02:26 UTC 2010 x86_64 GNU/Linux virtualbox-3.1 3.1.4-57640_Ubuntu_karmic

comment:2 Changed 4 years ago by hansb

After the upgrade to Virtualbox 3.1.6. behaviour is unchanged. The guest system needs to be restarted once in a while because its IP becomes 'unreachable' from the host side.

The error seems to be statistically distributed, e.g. sometimes it works two days straight, then it gets unreachable twice within a couple of hours without any change in circumstances, traffic, etc.

Changed 4 years ago by hansb

comment:3 Changed 4 years ago by frank

Tried to reproduce but so far without success. I had a WinXP guest attached to a vboxnet0 host interface running for more than two days, the guest was always pingable.

comment:4 Changed 4 years ago by hansb

Frank,

Thank you for looking into this matter.

I have a legacy web application running in there and a little script on the Ubuntu host, which checks every 2 minutes and restarts the VM once it ceases to be pingable. The web application gets continuous moderate http traffic (not excessive by any means).

Restarts are logged, here's the log as of today:

Thu Feb 25 10:13:22 CET 2010 restarted Fri Feb 26 03:04:22 CET 2010 restarted Sat Feb 27 15:25:14 CET 2010 restarted Tue Mar 2 08:31:21 CET 2010 restarted Wed Mar 3 09:52:22 CET 2010 restarted Sun Mar 7 13:43:22 CET 2010 restarted Mon Mar 8 01:13:15 CET 2010 restarted Mon Mar 8 18:58:21 CET 2010 restarted Mon Mar 8 19:31:21 CET 2010 restarted Tue Mar 9 22:46:15 CET 2010 restarted Sat Mar 13 22:16:22 CET 2010 restarted Sun Mar 14 00:58:21 CET 2010 restarted Sun Mar 14 10:19:14 CET 2010 restarted Mon Mar 15 17:13:14 CET 2010 restarted Wed Mar 17 00:49:22 CET 2010 restarted Thu Apr 8 21:31:22 CEST 2010 restarted Mon Apr 12 05:01:15 CEST 2010 restarted Mon Apr 12 09:16:13 CEST 2010 restarted Tue Apr 13 15:52:21 CEST 2010 restarted Wed Apr 14 16:49:15 CEST 2010 restarted Wed Apr 14 18:37:11 CEST 2010 restarted Thu Apr 15 09:31:14 CEST 2010 restarted

comment:5 Changed 4 years ago by hansb

Sun Mar 14 10:19:14 CET 2010  restarted
Mon Mar 15 17:13:14 CET 2010  restarted
Wed Mar 17 00:49:22 CET 2010  restarted
Thu Apr 8 21:31:22 CEST 2010  restarted
Mon Apr 12 05:01:15 CEST 2010  restarted
Mon Apr 12 09:16:13 CEST 2010  restarted
Tue Apr 13 15:52:21 CEST 2010  restarted
Wed Apr 14 16:49:15 CEST 2010  restarted
Wed Apr 14 18:37:11 CEST 2010  restarted
Thu Apr 15 09:31:14 CEST 2010  restarted

comment:6 Changed 4 years ago by hansb

Thu Feb 25 10:13:22 CET 2010  restarted
Fri Feb 26 03:04:22 CET 2010  restarted
Sat Feb 27 15:25:14 CET 2010  restarted
Tue Mar 2 08:31:21 CET 2010  restarted
Wed Mar 3 09:52:22 CET 2010  restarted
Sun Mar 7 13:43:22 CET 2010  restarted
Mon Mar 8 01:13:15 CET 2010  restarted
Mon Mar 8 18:58:21 CET 2010  restarted
Mon Mar 8 19:31:21 CET 2010  restarted
Tue Mar 9 22:46:15 CET 2010  restarted
Sat Mar 13 22:16:22 CET 2010  restarted
Sun Mar 14 00:58:21 CET 2010  restarted
Sun Mar 14 10:19:14 CET 2010  restarted
Mon Mar 15 17:13:14 CET 2010  restarted
Wed Mar 17 00:49:22 CET 2010  restarted
Thu Apr 8 21:31:22 CEST 2010  restarted
Mon Apr 12 05:01:15 CEST 2010  restarted
Mon Apr 12 09:16:13 CEST 2010  restarted
Tue Apr 13 15:52:21 CEST 2010  restarted
Wed Apr 14 16:49:15 CEST 2010  restarted
Wed Apr 14 18:37:11 CEST 2010  restarted
Thu Apr 15 09:31:14 CEST 2010  restarted

comment:7 Changed 4 years ago by Reiner030

Hi,

with the Version 3.1.4 and 3.1.6 i had never network loss, but after some hours / running for several days mostly about every 24h, virtualbox become a "back to the feature" timeslot...

=> it went 15-25 minutes back in the time for about half an hour ... after it it goes back to normal time.

With 3.1.8 I have first time network outages.

They are disconnecting even the own virtualbox shares and the dns resolving hangs (direct ip pings/connects seems to work when i tried...)

Host System: debian lenny, actual Guest System: Windows XP, actual

comment:8 follow-up: ↓ 9 Changed 4 years ago by aleksey

There has been a number of changes to host-only networking since 3.1.8. Could you please try 3.2.8?

comment:9 in reply to: ↑ 8 Changed 4 years ago by hansb

Could you please try 3.2.8?

Sorry, can't test this with 3.2.8, as this configuration does not exist any more.

comment:10 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

As the original reporter cannot test if a newer release fixes the issue, I will close this bug. Please reopen if this issue is still present and attach a VBox.log file of such a VM session running on VBox 3.2.8 or later in that case.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use