VirtualBox

Ticket #6272 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

mouse cursor can't move in the direction where the VM window is stepping outside the screen

Reported by: mhanor Owned by:
Priority: major Component: other
Version: VirtualBox 3.1.4 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

I can reproduce this on a XP SP3 32 bit host, using 2 guests:

  1. XP SP3 32 bit, VT-X and NX enabled; 2D,3D enabled, GA installed in safe mode
  1. live disto SLAX 6.1.2, no NX, no VT-X, no usb, no audio, no network, no 2D&3D acceleration, no GA; text mode session, gpm enabled (mouse server)

The cursor is having very hard time moving torward the VM window's edge(s) that are outside the visible screen. Keyboard&mouse input must be captured.

Attachments

VBox.log Download (54.3 KB) - added by mhanor 4 years ago.
xp sp3 32 bit guest

Change History

Changed 4 years ago by mhanor

xp sp3 32 bit guest

comment:1 Changed 4 years ago by mhanor

VB 3.1.6 is still affected, the cursor is having very hard time moving torward the VM window's edge(s) that are stepping outside the visible screen.
Mouse input must be captured, mouse integration must be disabled.

comment:2 Changed 4 years ago by mhanor

the bug is still present in VB 3.2.0 beta1

comment:3 Changed 4 years ago by mhanor

VB 3.2.4 comes with no change

comment:4 Changed 4 years ago by capfed76

I was about to file a bug for this, but finally found this one while searching the site. I've noticed this long ago, I confirm that if you move the VM's window slightly outside the screen the mouse pointer cant be moved over a certain invisible border so you have to move the virtual machine's window to fit inside your screen to be able to work with it, tested in 3.2.4.

comment:5 Changed 3 years ago by mhanor

VB 4.0 beta1 seems to be free of this minor bug

comment:6 Changed 3 years ago by mhanor

You can close this ticket. VB 4.0.6 (win32) is also free of this bug.

comment:7 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use