VirtualBox

Ticket #6246 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

XP guest freezing for two to three seconds at a time

Reported by: DK707 Owned by:
Priority: major Component: other
Version: VirtualBox 3.1.4 Keywords: freezing, hanging, freeze, hang
Cc: Guest type: Windows
Host type: Linux

Description

After installing VirtualBox 3.1.4 I have started to experience freezing of my XP guest for durations of one to two seconds at a time. The freezing most often occurs when quickly manipulating directories/files in Window's explorer. It also happens on regular occasion when quickly responding to system dialog boxes. The problem does not occur when I am working within an application so long as I don't bring up a system dialog box.

Example 1: If I open "MY Computer" and click on the "My Documents" link, the system will pause for a two or so seconds and then open the folder. If I then quickly move my mouse over the back button it will take a couple seconds before the back button changes appearance to indicate that my mouse is over-top the control. If I click before getting this visual feedback the system will ignore my mouse input.

Example 2: If I open Wordpad, type some text, and then close the application the system will bring up a dialog box asking me if I want to save changes to the document. If I quickly attempt to press NO the guest will freeze for a second or two and then the application will exit. If I allow the dialog box to remain on the screen for a few seconds before I click, the application will exit immediately as desired.

This freezing bug is definitely being caused by version VirtualBox 3.1.4. If I re-install 3.1.2 the problem goes away entirely and the system is very responsive to user input.

I have tried disabling Guest additions, disabling VT-x, disconnecting the Network, etc. None of these changes seem to have any effect on the freezing issue.

FYI: My host is running Fedora 12 64 bit on an Core i7 processor. The output of uname -r is :2.6.31.12-174.2.19.fc12.x86_64

Attachments

VBox.log.1 Download (108.5 KB) - added by MichaelFischer 4 years ago.
Log of experiments with VirtualBox 3.1.4.
DK707_Vbox_freezing.log Download (90.7 KB) - added by DK707 4 years ago.
Generated after creating freezing symptoms with dialog boxes and wordpad

Change History

comment:1 Changed 4 years ago by MichaelFischer

I had a similar experience of sudden CPU saturation after upgrade to VirtualBox 3.1.4.

I also noticed pauses with dialog boxes, but the easiest way to experience the problem is to open Games->Spider Solitare. Start a game, then attempt to drag a card from one pile to another. Instead of smooth motion, the card will "stick" for a second or two and then jump to the mouse location. Now open Windows Task Manager and select Performance tab. Repeat above: Every time a card is dragged, CPU Usage shoots up to 100% for a second or two, then drops back. Ordinary mouse movements are okay.

The guest works fine under VirtualBox 3.1.2 and only fails after upgrade to 3.1.4. Same problem occurs both before and after upgrading the guest additions to 3.1.4. I've reverted everything to 3.1.2 and all is well again.

Host: Fedora 11 64 bit on a Core i7 processor, kernel 2.6.30.10-105.2.23.fc11.x86_64. Guest: Windows XP.

comment:2 Changed 4 years ago by sandervl73

VBox.log of such freezing sessions please.

Changed 4 years ago by MichaelFischer

Log of experiments with VirtualBox 3.1.4.

Changed 4 years ago by DK707

Generated after creating freezing symptoms with dialog boxes and wordpad

comment:3 Changed 4 years ago by DK707

I have attached my log file.

I am getting "Could not send the mouse event to the Virtual Mouse" errors during the session.

When I shut the system down, I received another group of seemingly unrelated errors related to time syncing.

comment:4 Changed 4 years ago by tekst

I'm also experiencing this issue with Fedora 12 x86_64: 2.6.31.12-174.2.22.fc12.x86_64, but with a Windows 7 guest.

The issue seems to be audio related. If I switch to alsa from pulseaudio, the issue is gone (but audio is choppy). Using pulseaudio, I've noticed that if I leave Windows Media Player open with a song, I can double click a directory without the freezing (otherwise a two second or so freeze occurs each time I try to go into a directory, probably due to the "click" sound made during the access).

I have also "fixed" the problem by disabling the audio device in Windows 7. Voila. No more lagged audio events. Virtualbox 3.1.2 did not have this issue.

comment:5 Changed 4 years ago by DK707

Based on the results from tekst, I changed the audio driver to ALSA from Pulseaudio. This has fixed the freezing on my system as well. The only difference for me is that the audio quality seems fine with either the ALSA or Pulseaudio driver on my system. I am running a no-name USB audio adapter.

Disabling the audio driver in the VirtualBox settings also solves the freezing issue.

comment:6 Changed 4 years ago by frank

So can everybody in this defect confirm that the problem is related to the PulseAudio backend? The freezes during explorer actions make sense as these action trigger sound output.

comment:7 Changed 4 years ago by frank

Oh, and all of you are using a Fedora 11 or Fedora 12 host, right? In that case it sounds like a duplicate of #6224.

comment:8 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

See there, should be fixed in SVN.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use