VirtualBox

Ticket #6241 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

3D Acceleration not available or working

Reported by: cmenser Owned by:
Priority: major Component: 3D support
Version: VirtualBox 3.1.4 Keywords:
Cc: Guest type: Linux
Host type: Solaris

Description

Somewhere between VB 3.1.0 on snv_128a and VB 3.1.4 on snv_131, the option for 3D Acceleration became greyed out, and the VMs I had that were working with 3D acceleration no longer supported 3D.

Change History

comment:1 Changed 4 years ago by cmenser

I was able to narrow it down a bit more. 3D works with VB 3.1.2 on snv_129 as well.

Some time this weekend, I will try upgrading my snv_129 BE with VB 3.1.4 and see if it works.

comment:2 Changed 4 years ago by cmenser

VB 3.1.4 on snv_129 has no 3D problems. So it looks like something changed in OpenSolaris that broke 3D, somewhere between snv_130 and snv_131.

I will BFU to snv_133 and see what happens.

comment:3 Changed 4 years ago by cmenser

Good news, snv_133 does support 3D in VB 3.1.4.

In case anyone is on one of the intermediary versions (snv_131 is still the current version in the development repository), either BFU to snv_133 or higher, or wait for the development repository to be updated to snv_133.

comment:4 Changed 4 years ago by cmenser

After doing an image-update upgrade from snv_129 to snv_133, 3D is again unavailable and broken.

My next step is to reinstall with the snv_133 ISO and see if that works.

Note: I also have a laptop, installed with with 2009.06 and image-updated to the snv_133, and am seeing the same 3D unavailability on it.

comment:5 Changed 4 years ago by ramshankar

If you're upgrading the guest OS, you should reinstall the guest additions, at least as far as Solaris and 3D are concerned and even otherwise I'd recommend reinstallation because kernel interfaces might have changed and not all the API VirtualBox uses can be deemed as set-in-stone.

comment:6 Changed 4 years ago by cmenser

Thanks for the suggestion. Unfortunately the problem has nothing to do with guest additions, or the guest OS at all. The problem is that VB on recent builds of OpenSolaris does not allow the 3D option to be enabled. That is to say, when running VB 3.1.4 on OpenSolaris snv_133 (the currently build in the development repository) the option for 3D Acceleration is not selectable; likewise VB guests which are configured with 3D and work with 3D under snv_129 (on the host), do not work when the host runs snv_130 or higher.

There are no changes in the guest configurations, the only variable is the build of OpenSolaris running on the host.

This problem seems significant as the 2010.spring release of OpenSolaris is approaching, and if this issue persists, 3D support will likely not work with it.

comment:7 Changed 4 years ago by ramshankar

This is a problem of the host OpenSolaris shipping with a broken link for /usr/lib/GL/amd64/libGL.so.1 and not with VirtualBox.

Verify by checking if the link is broken. ls -l /usr/lib/GL/amd64/libGL.so.1

IIRC, To fix it, I just fixed the broken link by making a from /var/run/opengl/lib/amd64/libGL.so.1 to /var/run/opengl/lib/64/libGL.so.1 (you may need to create the "64" subdir).

comment:8 Changed 4 years ago by cmenser

You are right!

I added the 64 directory and an link pointing to the amd64, as you recommended, and 3D works perfectly.

Thank you!

Do you know if that broken link has a ticket/RFE/whatever to get the opensolaris developers to fix it?

Thanks again!

comment:9 Changed 4 years ago by ramshankar

They've already been informed of the breakage and they've apparently fixed it as mentioned here:  http://bugs.opensolaris.org/bugdatabase/view_bug.do?bug_id=6924423 (in snv_134 I believe)

comment:10 Changed 4 years ago by cmenser

Great news.

I appreciate your help.

comment:11 Changed 4 years ago by ramshankar

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use