VirtualBox

Ticket #6199 (new defect)

Opened 4 years ago

Last modified 4 years ago

USB-devices Nokia and Palm not working anymore on guest

Reported by: willem_se Owned by:
Priority: major Component: USB
Version: VirtualBox 3.1.4 Keywords: palm nokia not working
Cc: Guest type: Windows
Host type: Mac OS X

Description

Running VirtualBox 3.1.4 on a Mac Leopard 10.5.8, guests Windows XP and Windows 7.

I've configured to use my Nokia XpressMusic and Palm T|X as "remote only" devices. The guests do not use the devices automatically (anymore). When I connect the device manually via the menu option devices the connection get lost when I try to hotsync my Palm device. So: hotsyncing is not possible anymore... When I try to manually connect my Nokia, VirtualBox says: "Failed to connect the USB device... USB device ... is in use by someone else". To be clear: the host is not using the device!

I tried to get things working by changing the option "remote only" to "any", but that is not a solution... Same for connect the devices before starting the guests.

My USB-stick works okay (setting: "remote: any").

To keep thing working I decided to reinstall the previous version of VirtulBox, 3.1.2.

Attachments

Windows 7-2010-02-14-23-45-29.log Download (67.0 KB) - added by willem_se 4 years ago.
Log Windows 7 guest

Change History

Changed 4 years ago by willem_se

Log Windows 7 guest

comment:1 Changed 4 years ago by willem_se

Edit: For your convenience: I uninstalled the Guest Additions 3.1.4, and then the host VirtualBox. Reinstalled version 3.1.2 on host and guests, and *everything* works fine, *without* having made any changes in the configuration!

comment:2 follow-up: ↓ 6 Changed 4 years ago by charlesclloyd

I just installed 3.1.4 on my Snow Leopard 10.6.2 (latest) and one of my USB devices is no longer accessible. This device has always had trouble with VBox -- it always required my unplug/re-plug to get it to be recognized each time I restarted the VBox instance which uses this device. I tried rebooting the VBox instances, installing the latest UserAdditions, rebooting the entire machine, waving a chicken over my head, etc. Nothing worked -- the USB device was always grayed out and inaccessible. I reverted back to VBox 3.1.2 (by downloading the previous version and reinstalling), and I am back in operation now. Evidence is pretty compelling that 3.1.4 introduced a regression in this area (which already had its issues, as mentioned above).

Just FYI: This USB device is a bit esoteric. Its a CyberRain AccessPoint for ZigBee wireless control of a lawn sprinkler system. To see the device:  http://www.cyber-rain.com/Products/products.aspx

comment:3 Changed 4 years ago by matschfant

Same Problem with ubuntu 9.10 as host and winxp as guest. I can't do any hotsync with my palm centro any more. I also go back to 3.1.2

comment:4 Changed 4 years ago by benjie

I'm running an OSX 10.6.2 host, and an XP SP3 guest. I updated to 3.1.4, and cold no longer connect to my USB Microchip PicKit2. When plugged in, it appeared disabled in the Devices -> USB Devices menu.

I reverted to VirtualBox 3.1.2, but did not downgrade the GuestAdditions or change settings. Now when I plug in the device, it once again appears enabled and checked in the Devices -> USB Devices menu, and it works well.

comment:5 Changed 4 years ago by daveu8282

I am seeing this with VB 3.1.4 under openSUSE Linux 11.1 as host and with Windows XP as guest. My USB device is a Palm T|X hotsync cable. It's listed in the USB Devices menu but in a disabled (unchecked) state. I can _sometimes_ do a successful hotsync if I managed to check the Palm device (under USB Devices) quickly enough after pressing the hotsync cable's sync button, but the majority of the time the hotsync hangs on the PDA side and never starts on the WinXP side.

comment:6 in reply to: ↑ 2 Changed 4 years ago by charlesclloyd

Replying to charlesclloyd:

I just installed the latest Snow Leopard 10.6.3 and updated to VBox 3.1.6 and this issue seems to have been fixed under this configuration. I am still having the same old problem with my CyberRain access point in that I am required to unplug the device and pug it back in in order for it not to be gray'd out in the USB device list. But this is as it was before VBox 3.1.4, so we're back to the way it was in 3.1.2, at least.

comment:7 Changed 4 years ago by daveu8282

I'm no longer seeing the problem with VBox 3.1.6. My Palm hotsync connection now works correctly with an openSUSE Linux 11.1 host and Windows XP guest.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use