VirtualBox

Ticket #6098 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

USB2.0 un Linux guests does no long work

Reported by: Reiner1210 Owned by:
Priority: major Component: USB
Version: VirtualBox 3.1.2 Keywords: USB2.0 Linux
Cc: Guest type: Linux
Host type: Linux

Description

Hello,

when I have assigned (before starting the VM) a USB (memory stick) device to a VM and USB2.0 is enabled I get the following during starting:

[code] Jan 30 09:59:42 sysresccd ehci_hcd 0000:00:0b.0: Unlink after no-IRQ? Controller is probably using the wrong IRQ. Jan 30 09:59:42 sysresccd usb 1-1: device not accepting address 2, error -110 code

If I disable USB2.0 it works

If I dont' assign it before starting the VM and assign it later nothing happens if USB2.0 is enabled but it works normal with USB2.0 disabled:

Host: 2.6.31.8-0.1-default #1 SMP 2009-12-15 23:55:40 +0100 x86_64 x86_64 x86_64 GNU/Linux

Guest: Linux sysresccd 2.6.24.07-alt17 #1 Sun Jun 22 07:54:22 UTC 2008 i686 AMD Athlon(tm) 64 X2 Dual Core Processor 6400+ AuthenticAMD GNU/Linux

Attachments

usb20.tgz Download (8.2 KB) - added by Reiner1210 4 years ago.
Log files
irq.txt Download (562 bytes) - added by Reiner1210 4 years ago.
cat /proc/interrupts from the guest
vbox-usb2.0.png Download (44.3 KB) - added by Reiner1210 4 years ago.
The attatched USB device
messages-1.0.txt Download (24.2 KB) - added by Reiner1210 4 years ago.
/var/log/messages in USB 1.0 case
messages-2.0.txt Download (24.2 KB) - added by Reiner1210 4 years ago.
/var/log/messages in USB 2.0 case
lsusb-1.0.txt Download (4.5 KB) - added by Reiner1210 4 years ago.
lsusb -v in USB 1.0 case
lsusb-2.0.txt Download (4.4 KB) - added by Reiner1210 4 years ago.
lsusb -v in USB 2.0 case

Change History

Changed 4 years ago by Reiner1210

Log files

comment:1 Changed 4 years ago by michaln

Could you please attach the full output of dmesg from the guest, as well as the output of 'cat /proc/interrupts'?

Also, what is "does no longer work" relative to? Did the exact same guest configuration work previously?

Changed 4 years ago by Reiner1210

cat /proc/interrupts from the guest

Changed 4 years ago by Reiner1210

The attatched USB device

Changed 4 years ago by Reiner1210

/var/log/messages in USB 1.0 case

Changed 4 years ago by Reiner1210

/var/log/messages in USB 2.0 case

Changed 4 years ago by Reiner1210

lsusb -v in USB 1.0 case

Changed 4 years ago by Reiner1210

lsusb -v in USB 2.0 case

comment:2 Changed 4 years ago by Reiner1210

I think it has worked in an older version but I don't know exactly which one it was.

Reiner

comment:3 Changed 4 years ago by Reiner1210

Perhaps it comes when usbfs was no longer used ?

R

comment:4 Changed 4 years ago by michaln

Not sure what usbfs you're referring to... but I'd be surprised if this particular configuration worked in any VBox version. At the same time I'm quite sure that most Linux guests work fine; the problem is caused by using the I/O APIC and at the same time not using ACPI.

comment:5 Changed 4 years ago by Reiner1210

The guest was a system based on the the system rescue CD (alternative kernel). In older days usbfs was require4d by virtual box and sometimes it wasn't. I'm not sure that this was the time the USB 2.0 support was broken, it was only a hint.

comment:6 Changed 4 years ago by michaln

VirtualBox still requires usbfs on the host, but how usbfs is accessed has changed. At any rate, that had nothing to do with the problem you're seeing.

The problem you're seeing should be fixed in the next maintenance release.

comment:7 Changed 4 years ago by michaln

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use