VirtualBox

Ticket #6094 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

DirectDraw doesn´t work with 2D-video-acceleration ==> Fixed in SVN

Reported by: kevinkk Owned by:
Priority: major Component: 3D support
Version: VirtualBox 3.1.2 Keywords: 2D-Acceleration
Cc: Guest type: Windows
Host type: Windows

Description

I wanted to play games like cossacks or age of empires in my Windows XP VM. This worked before the new version without 2D-video-acceleration. with the new version i enabled this but installed my windows again. those games don´t work with that acceleration. not even the gameboy emulator works with directdraw then. but my windows does not interrupt or something like that. the qualitiy of the pictures i can see is very bad and it has stripes and i can see only the upper half of the original screen. so it is streched. but i do not get any errors.

i think that´s a bug and wanted to report it. what log files in which configuration do you need?

Attachments

VBox.log.2 Download (63.9 KB) - added by kevinkk 4 years ago.
Last log

Change History

comment:1 follow-up: ↓ 2 Changed 4 years ago by kevinkk

 http://www.gamershell.com/download_4070.shtml here´s one demo of the game i´m playing. the demo of cossacks back to war is not available any more.

Changed 4 years ago by kevinkk

Last log

comment:2 in reply to: ↑ 1 Changed 4 years ago by kevinkk

Replying to kevinkk:

 http://www.gamershell.com/download_4070.shtml here´s one demo of the game i´m playing. the demo of cossacks back to war is not available any more.

the log is when i tested the game with 2D-acceleration enabled.

comment:3 follow-up: ↓ 4 Changed 4 years ago by misha

Does it still work with 2D acceleration disabled?

comment:4 in reply to: ↑ 3 Changed 4 years ago by kevinkk

yes of course. if i enable it the game doesn´t work. with it disabled i can play that game. it depends only from the setting. no errors. nothing.

comment:5 Changed 4 years ago by Mo6eB

I am also experiencing this problem in VirtualBox 3.1.4. Here are two screenshots of the title screen to Command and Conquer:

 Without 2D acceleration enabled

 With 2D acceleration enabled

comment:6 Changed 4 years ago by kevinkk

Well on my screen it looks exactly the same. doesn´t matter which game i start.

comment:7 Changed 4 years ago by misha

We've reproduced the issue, and will fix it soon.

comment:8 Changed 4 years ago by weller99

Hi, I'm experiencing something similar but not with playing games, and I'm not sure if it's the same thing. With 2D acceleration turned on, playing a simple AVI video with any player (vlc, mplayer) eats up 100% of my cpu and results in a slide show with imperfect frames, at a rate of 1 frame every 5 seconds. If I disable 2D acceleration, it it watchable but it's not smooth like it would be natively - perhaps 10 frames per second.

My setup: HOST: Ubuntu Lucid Lynx 64-bit with 2.6.33 kernel; ati radeon display driver. Virtualbox 3.1.4 (3.1.2 w/ 2.6.32 kernel - same issue) Guest; Windows XP 32-bit, 2cpus, AMD-v on, 128M video mem.

Chapter 4 in the manual states, "The driver sends all overlay commands to the host through a special communication tunnel implemented by VirtualBox, in order for the host to perform the requested 2D operations via the host's programming interfaces.". Is there any way to confirm or check whether the host's programming interface is correct? could the host driver be at fault or not be compatible in any way?

Thanks ;)

comment:9 Changed 4 years ago by kevinkk

how many cores does your system have? if you have 2 your Virtual Machine shouldn´t have 2 cores/cpus. this could slow your system.

i did not recognize this issue because i never watched movies in the VM. but it is interesting.

you should maybe add the logfile of the VM when you have this issue

comment:10 Changed 4 years ago by weller99

Thanks for the tip. I have 4 cores (AMD Phenom II X4 965). I did lower it to 1 cpu and had no effect. I just about did every permutation of options you can think of to get this working ;(

I'm curious if you have the movie-playing issue too then. any standard 350M xvid avi does it for me. i plan on using linux for the bulk of my video playing anyways - it's just that sometimes, there are the odd cases where things only run in Windows. certain olympic videos didn't run in moonlight, for example.

I'll follow-up with some logs.

comment:11 Changed 4 years ago by weller99

I know it says never paste log files here, but it's only 3 lines! 00:14:16.095 2D is supported! 00:15:38.471 Switching Gl mode on 00:15:51.466 Switching Gl mode off The Gl mode on was when I started the video. The off was when I killed it. I didn't see a log level option, as I think increasing the verbosity might help. Do you think that upgrading from directx 9c to 11 will help?

comment:12 follow-up: ↓ 13 Changed 4 years ago by weller99

Here's an update. I updated DirectX, and it made no change. VLC allows you to select the video output type - directX, directX-3D, openGL, Windows GDI Video output.

directX eats up 100% of my CPU and gives me the 1 frame every 5 seconds as I mentioned. DirectX-3D results in a black screen (I did select the experimental 3d acceleration when installing the virtualbox guest addition drivers). OpenGL and Windows GDI were almost identical - watchable at about 10 frames per second in native mode, but only about 5 frames per second in full screen mode.

Also, the log output was identical for opengl and directx. Both attempts state the same thing: "switching Gl mode on" and "switching Gl mode off" when playing the video and closing the app.

comment:13 in reply to: ↑ 12 Changed 4 years ago by misha

Replying to weller99: It's strange that your log is so short. In any way make sure you have at least 32M of video memory configured for your virtual display adapter in VM settings.

comment:14 Changed 4 years ago by weller99

I have 128M, the max that it would allow me.

comment:15 Changed 4 years ago by misha

  • Summary changed from DirectDraw doesn´t work with 2D-video-acceleration to DirectDraw doesn´t work with 2D-video-acceleration ==> Fixed in SVN

We've fixed the issue. The fix will be available in the next VBox release. For those willing to try the fix: please post me an e-mail at mikhail dot sennikovsky at sun dot com I'll then send you a link to the test build.

comment:16 Changed 4 years ago by elio.voci

VirtualBox-2010-04-01-22-03-31-lin32-3.1-3.1.7-r59656.run does not work for me. Not only the problem of vertical lines remains, but with this audio does not work (guest additions updated). I run Windows XP SP2 guest on Debian 2.6.32-3-686 host,

comment:17 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Should be fixed in 3.1.8

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use