VirtualBox

Ticket #6076 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Unable to use a USB bluetooth key

Reported by: OlivierV Owned by:
Priority: minor Component: USB
Version: VirtualBox 3.1.2 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

I have using Virtualbox on Kubuntu 9.04 as host and Windows XP as guest. All USB flash drives, mouse, printers, works good with Virtualbox, but not my MSI bluetooth key

When I insert this device, in messages dmesg says :

[  547.252615] usb 6-1: new full speed USB device using uhci_hcd and address 3
[  557.423057] usb 6-1: configuration #1 chosen from 1 choice
[  557.480982] Bluetooth: Generic Bluetooth USB driver ver 0.3
[  557.485792] usbcore: registered new interface driver btusb

When I try to connect the key in the Virtualbox, I get this on the screen :

Echec : le périphérique USB ISSCBTA [0373] n'a pas été connecté à la machine virtuelle virtualbox_xp. Failed to create a proxy device for the USB device. (Error : VERR_READ_ERROR) Détails : Code de résultat : NS_ERROR_FAILURE (0x80004005) Composant :Console Interface : IConsole {6375231a-c17c-464b-92cb-ae9e128d71c3}

And in VBox.log I see the error:

00:00:13.619 ERROR [COM]: aRC=NS_ERROR_FAILURE (0x80004005) aIID={6375231a-c17c-464b-92cb-ae9e128d71c3} aComponent={Console} aText={Failed to create a proxy device for the USB device. (Error: VERR_READ_ERROR)} aWarning=false, preserve=false

This device is a usb MSI bluetooth key. lsusb says :

Bus 006 Device 003: ID 1131:1001 Integrated System Solution Corp. KY-BT100 Bluetooth Adapter

How to fix this ?

Olivier V

Attachments

VBox.log Download (39.6 KB) - added by OlivierV 4 years ago.
virtualbox_bluetooth.jpg Download (212.2 KB) - added by OlivierV 4 years ago.

Change History

Changed 4 years ago by OlivierV

Changed 4 years ago by OlivierV

comment:1 Changed 4 years ago by OlivierV

The problem is solved with Virtualbox 3.2 on Kubuntu 10.04.

Great !

comment:2 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use