VirtualBox

Ticket #6069 (closed defect: obsolete)

Opened 10 years ago

Last modified 3 years ago

Execution state is lost - only with differencing disks

Reported by: rjk Owned by:
Component: other Version: VirtualBox 3.1.2
Keywords: Execution state lost with differencing disks Cc:
Guest type: Windows Host type: Windows

Description (last modified by aeichner) (diff)

Basically, if I shut down the machine, then start it again, all changes which should have been written to disk are lost. This does not apply to reboots, or to saved states. If I shut the machine down, then take a snapshot, the changes are saved as expected. T

This is occurring on a Windows 7 x64 host, and Windows XP guests. I believe that the problem is not limited to XP guests. This occurs only when using differencing disks, regular disks are not affected as such.

Please see [url] http://forums.virtualbox.org/viewtopic.php?f=7&t=26848&p=121030[/url] for details, my posts are from "rjk"

Attached are four logs: the first two are the most recent from one VM that was in a saved state when the logs were collected, the next two are from a different VM that was running when they were collected.

Attachments

First machine saved state log.txt Download (64.9 KB) - added by rjk 10 years ago.
First machine saved state log
first machine next oldest log.txt Download (97.2 KB) - added by rjk 10 years ago.
First machine next oldest log
second machine running log.txt Download (46.5 KB) - added by rjk 10 years ago.
second machine running log
second machine next oldest log.txt Download (64.9 KB) - added by rjk 10 years ago.
second machine next oldest log

Change History

Changed 10 years ago by rjk

First machine saved state log

Changed 10 years ago by rjk

First machine next oldest log

Changed 10 years ago by rjk

second machine running log

Changed 10 years ago by rjk

second machine next oldest log

comment:1 Changed 10 years ago by sandervl73

The last question by Mark Cranness in the topic is a valid one.

comment:2 Changed 10 years ago by rjk

It seems that my impression of immutable disks was inaccurate: My understanding of an immutable disk was that the base image would never be written to, and all changes would go to a differencing VDI, and that was it. However it seems that the VBox developers put a nice little plot twist in, and each time the VM is stopped, the handy little differencing disk would be deleted.

Can I change this behavior without wiping out my installs? Or am I forever doomed to create a new snapshot every time I shut the machine down?

I would like to turn this ticket into a feature request: I would like to have the immutable disk functionality, (I.E., one base image) but without the auto-deletion of the VDI, so all changes [i]to the differencing VDI'si would not be discarded. Adding this as a nice little GUI button would be a bonus too. As I understand from further reading, this is already possible, if the base VDI is prepared correctly, but it is too late for me now, as I am already running with an immutable disk. Since it seems to be already possible, the GUI button would just be a series of cmdline operations.

I am aware that this could have severe disk performance implications for guest machines, but sometimes this doesn't matter a whole lot.

comment:3 Changed 3 years ago by aeichner

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)

Please reopen if still relevant with a recent VirtualBox release.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use