VirtualBox

Ticket #6043 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

Seamless mode issues with multiple monitors in 3.1.2

Reported by: vb userman Owned by:
Priority: major Component: GUI/seamless
Version: VirtualBox 3.1.2 Keywords: seamless external monitor
Cc: Guest type: Windows
Host type: Windows

Description

Starting in seamless mode when I have an external monitor has a serious issue. I sometimes see a partial desktop of the guest OS and partial app. Sometimes I see only a ghost of the guest app and guest taskbar on my second monitor. Switching to full screen and back to seamless fixes it. For my use, this makes 3.1.2 unusable.

Attachments

VBox.log Download (38.0 KB) - added by vb userman 4 years ago.
vbox.log from seamless mode errors
seamless problem.jpg Download (357.5 KB) - added by vb userman 4 years ago.
Seamless mode issue
VBox.log.1 Download (38.2 KB) - added by vb userman 4 years ago.
log from most recent seamless mode
Seamless issue - move left.jpg Download (284.8 KB) - added by vb userman 4 years ago.
When I move the browser window to the left. Notice grey area.
seamless issue - move right.jpg Download (185.2 KB) - added by vb userman 4 years ago.
When I move the browser window to the right. Notice desktop showing and size of the window is much too small
Seamless 48MB VRAM.jpg Download (255.6 KB) - added by vb userman 4 years ago.
Seamless issue with 48MB VRAM

Change History

comment:1 Changed 4 years ago by vb userman

I should add that this is a new problem after upgrading to 3.1.2 from 3.0.8.

comment:2 Changed 4 years ago by Technologov

please provide VBox Log

-Technologov

Changed 4 years ago by vb userman

vbox.log from seamless mode errors

comment:3 Changed 4 years ago by vb userman

Log attached. In this case, I had a ghost of the application on my second monitor. This log is from Windows 7. I have seen this on XP and Vista too.

comment:4 Changed 4 years ago by Dsen

I'd tried to reproduce that issue with no success, using vista host & xp guest for that. I'd used fresh VBox sources & latest Guest Additions. Entering "Seamless Mode" from the main monitor (where the host task-bar is located) works nice. Entering seamless from the second monitor is not work but I can't recall the fact what it was working before, it was not just implemented to work on second monitor.

Could you please describe me better how to reproduce that issue? I need at least to know which the monitor you are starting seamless - the main (where the host task-bar is situated) or the second (which just extends one virtual desktop for the main monitor)? I also need to know what amount of video memory set for that guest and both monitors resolutions.

And if that issue is reproducible - please attach some screen-shot here.

Thanks in advance!

comment:5 Changed 4 years ago by vb userman

I will reproduce it in a couple of hours when I get into the office. I am starting seamless mode programatically. It starts on my main monitor. As soon as vbox enters seamless, I see the problems. Ctrl-L + Ctrl-L to go out and back into seamless always fixes it. The problem happens about once out of for or five times starting vbox in seamless mode.

I tried to attach a screen shot when I created the ticket. This system will only accept small attachments. Is there somewhere else I can put it?

comment:6 Changed 4 years ago by Dsen

Could you please convert the screen-shot to jpeg or png format or/and may be scale it a little if necessary to fit attachment-size restrictions of 1MByte?

Changed 4 years ago by vb userman

Seamless mode issue

Changed 4 years ago by vb userman

log from most recent seamless mode

comment:7 follow-up: ↓ 8 Changed 4 years ago by vb userman

Screen shot and log are now attached. Notice the right side of the browser window and the taskbar. They are both cut off by a couple of inches.

comment:8 in reply to: ↑ 7 Changed 4 years ago by vb userman

Replying to vb userman:

Screen shot and log are now attached. Notice the right side of the browser window and the taskbar. They are both cut off by a couple of inches.

This screen shot was taken on my main monitor.

Changed 4 years ago by vb userman

When I move the browser window to the left. Notice grey area.

Changed 4 years ago by vb userman

When I move the browser window to the right. Notice desktop showing and size of the window is much too small

comment:9 Changed 4 years ago by vb userman

More screenshots are attached. One one, I moved the browser window to the right. Notice how small the seamless area is. Also notice the guest desktop is showing.

In the second, I moved the seamless app to the left. Notice the grey area to the left of the browser window.

In both, I should have had a full page browser window showing all of the site I was viewing.

comment:10 Changed 4 years ago by Dsen

Please tell me what amount of video memory that guest have and whats the resolution of both monitors.

Thanks in advance!

comment:11 Changed 4 years ago by vb userman

Video memory is 12MB. RAM is 512MB. Screen resolution of the primary monitor (laptop) is 1440x900. The secondary is 1920x1080.

comment:12 follow-up: ↓ 13 Changed 4 years ago by Dsen

Could you please provide guest with at least 32MB-48MB video memory and check what issue is present. I think 12MB (too low amount) could cause that issue. I've the same resolutions of my laptop & external displays here too.

comment:13 in reply to: ↑ 12 Changed 4 years ago by vb userman

Replying to Dsen:

Could you please provide guest with at least 32MB-48MB to check what issue is present. I think 12MB (too low amount) could cause that issue too.

I will try that now. If this is the case, is there a way I could cause it to happen more often? I see it intermittently, maybe every 5 restarts.

comment:14 Changed 4 years ago by vb userman

I increased the vram to 48MB. Now I have a problem every time I start it. I attached another screen shot "seamless 48MG VRAM.jpg"

Changed 4 years ago by vb userman

Seamless issue with 48MB VRAM

comment:15 Changed 4 years ago by nikitin

Same problem for me with 3.1.2 (max os x leopard host, windows xp guest). Switching to full screen then back again doesn't fix the issue for me.

comment:16 Changed 4 years ago by Dsen

The same attributes (and monitor's resolutions) I have here and all works fine (host=vista, guest=xp, latest VBox, latest guest additions). May be that last thing you are observing constantly after increasing video memory is related to Windows 7, but previous thing - before increasing guest video memory - I think might be caused by too low amount of video memory. At least first thing was really strange, there were some artifacts on screen-shots. But last - is only vertical shift - that could be something other. Could you please test there is always the same vertical shift in case of 48MB of video memory? Also, is it possible to test that on Windows Vista?

P.S. Currently I'm working on huge task on rewriting almost whole GUI of running VM, including all the modes (windowed, fullscreen, seamless), so I just hope that seamless issue will be fixed by that rework. I simple would propose to wait until next major release. Thats quite old code and will be rewritten anyway nearest time.

comment:17 Changed 4 years ago by vb userman

I can try it on Vista but not until tomorrow. We have see the problem on XP. What is the timing for the next major release? I am building a product based on vbox and can't wait long. Sticking with 3.0.8 will be painful.

Yes, I do get the same vertical shift with every run of vbox in seamless with 48MB video ram. I get it when using only my single laptop monitor.

comment:18 Changed 4 years ago by Dsen

Ok, if that vertical shift - is the only remaining issue after increasing guest Video RAM to 48MB then the old artifacts issues was exactly because of low Video RAM amount. So we have another issue remaining - that vertical shift.

Could you please check if the same vertical shift appears in both cases - "single laptop display configuration" and "multiple monitors configuration containing laptop display and external monitor"? If that shift similar in both cases - then the problem is not linked to multi-monitor setup at all. Also I need to know if the same vertical shift present in case of Windows Vista host. And, btw, which is your guest os? And do you have other guests, XP for example? I'm asking that because issue could be not in GUI but in Guest Additions because they performs half of seamless functionality anyway.

comment:19 Changed 4 years ago by vb userman

The vertical shift is present with single or multiple monitors. I will need to test for the original problem with multiple monitors. I stopped as soon as I saw the vertical shift. I won't be able to do that until tomorrow.

comment:20 Changed 4 years ago by lonniebiz

If I enable seamless mode, while the guest is located in my second monitor, the right-3rd of the screen continues to display the guest desktop.

When I enable seamless mode, while the guest is located in my primary monitor, it works, but I'm unable to drag guest windows to any other monitor, but the primary.

The main goal is to be able to drag guest-os-windows into any monitor provided by the host OS.

I use Ubuntu Desktop 64 bit as my host OS, and I experience the above behavior running Windows XP as my guest OS.

Also discussed here:  https://bugs.launchpad.net/virtualbox/+bug/534160

comment:21 Changed 4 years ago by poetzsch

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #1322.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use