VirtualBox

Ticket #604 (closed defect: duplicate)

Opened 7 years ago

Last modified 4 years ago

Seamless windows doesn't work with multi monitors (nvidia twin view)

Reported by: jay Owned by:
Priority: minor Component: GUI/multiview
Version: VirtualBox 1.5.0 Keywords:
Cc: Guest type: other
Host type: other

Description

The seamless window feature doesn't work correctly on the first screen however when dragging the vbox window to the second screen and pressing Right Crtl + L it works fine.

I attached screenshots so that you can see the actual problem.

Attachments

virtualbox-1.5.0-seamless-windows-bug.png Download (123.7 KB) - added by jay 7 years ago.
Only a part of the window is shown and you can also see the background
Screenshot-1.png Download (197.0 KB) - added by jay 7 years ago.
If no windows are opened in the virtual machine, there is only a small section of the background visible
screen.png Download (163.5 KB) - added by Thalic 7 years ago.
Seamless window bug on system with one monitor.

Change History

Changed 7 years ago by jay

Only a part of the window is shown and you can also see the background

Changed 7 years ago by jay

If no windows are opened in the virtual machine, there is only a small section of the background visible

comment:1 Changed 7 years ago by Thalic

The bug is also present in single monitor configurations. The region copied from the guest screen does not match the window position inside the guest screen.

(Host and Guest are both XP SP2, host has nVidia GFX card)

comment:2 Changed 7 years ago by Dsen

To jay:

The seamless window feature doesn't work correctly on the first screen however when dragging the vbox window to the second screen and pressing Right Crtl + L it works fine.

  1. After that it works fine on both the monitors?
  1. Is this positioning ("Only a part of the window is shown and you can also see the background") error appears every time or it is one-time problem?
  1. Is this positioning error presents on both monitor?
  1. Are your monitors has similar or different pixel resolution (at the moment of reproducing)?
  1. Is some guest's window part visible on the second monitor when you've entered the seamless mode on the first monitor and locate the guest window partially on the first monitor?

I'm just trying to understand the problem and problem difference between the twin-view and xinerama (610 defect).

Thank you in advance.

comment:3 Changed 7 years ago by Dsen

To Thalic:

What a bug is present on single monitor configuration? Could you please describe it further?

Changed 7 years ago by Thalic

Seamless window bug on system with one monitor.

comment:4 Changed 7 years ago by Dsen

Thalic, is this common behavior of Seamless Mode or a special condition reached by some way on your system? What is also the amount of video-ram available for the VirtualBox? Could you also please check the Seamless Mode with increased video-ram value then?

Thank you in advance.

comment:5 Changed 7 years ago by Thalic

To Dsen:

The problem occured everytime I switched to seamless mode. The screenshot was made with 8MB of video memory. If I increase it to 16MB it runs flawlessly as far as i can tell. As in normal fullscreen mode 8MB was enough (1600x1200x32bit) I didn't even think of increasing the amount of video memory...d'Oh.

Thanks!

comment:6 Changed 7 years ago by Dsen

To Thalic:

You are welcome :) Btw, may be this is not necessary 16MB, you can just check the necessary video memory value yourself by verifying the correct Seamless work. In latest releases user will be notified if the current value is not enough. Thank you for your cooperation :)

To jay:

Could you please answer my questions? Thank you in advance.

comment:7 Changed 7 years ago by jay

To Thalic:

I am sorry I didn't respond sooner.

1) No it just works fine on the second screen. I can't drag any vbox windows from one screen to the other.

2) It appears everytime pressing Crtl+L on the first screen

3) No, only on the first screen

4) My first monitor (notebook display 17") has a resolution of 1920x1200 and the second monitor (Samsung Syncmaster) has a resolution of 1680x1050.

5) no

comment:8 Changed 6 years ago by frank

  • Component changed from other to GUI

comment:9 Changed 6 years ago by frank

  • Component changed from GUI to GUI/multiview

comment:10 Changed 4 years ago by poetzsch

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #1322.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use