VirtualBox

Ticket #6031 (closed defect: worksforme)

Opened 4 years ago

Last modified 4 years ago

vboxdrv kernel stacktrace on Fedora 12 x86_64

Reported by: john.southworth Owned by:
Priority: critical Component: network
Version: VirtualBox 3.1.2 Keywords:
Cc: Guest type: other
Host type: Linux

Description

I'm using the latest release of VirtualBox on Fedora 12 x86_64. One of the virtualbox drivers is causing a kernel stacktrace when booting up the virtual machines. This makes virtualbox unusable. Its an intermittent problem. I can say that it was working fine in Fedora 11 before I upgraded to 12. I can also verify that this is not a problem with the i686 version as it doesn't happen on my laptop. I've tried to go back a version to 3.1.0 with the same issue. It is always a problem with the network collision statistics. It is a divide error, I'm assuming its because there are no collisions and its dividing by zero. The card varies if i disable vboxnet0 it will stacktrace on eth1, if i disable eth1 it stacktraces on eth0 etc.

This is a copy of the stacktrace:

divide error: 0000 #1 SMP last sysfs file: /sys/devices/virtual/net/vboxnet0/statistics/collisions CPU 2 Modules linked in: vboxnetadp vboxnetflt vboxdrv fuse nfs fscache nfsd lockd nfs_acl auth_rpcgss exportfs sunrpc ipv6 dm_multipath uinput snd_hda_codec_realtek snd_hda_intel snd_usb_audio snd_usb_lib snd_rawmidi snd_hda_codec snd_seq snd_seq_device nvidia(P) snd_pcm uvcvideo snd_timer snd_hwdep i2c_nforce2 amd64_edac_mod snd videodev v4l1_compat v4l2_compat_ioctl32 i2c_core edac_core snd_page_alloc soundcore firewire_ohci forcedeth k8temp firewire_core crc_itu_t serio_raw ata_generic pata_acpi pata_amd sata_nv floppy usb_storage [last unloaded: vboxdrv] Pid: 7115, comm: VirtualBox Tainted: P 2.6.31.9-174.fc12.x86_64 #1 empty RIP: 0010:[<ffffffffa0c91447>] [<ffffffffa0c91447>] g_abExecMemory+0x41687/0x180000 [vboxdrv] RSP: 0018:ffff8800c68c9ba8 EFLAGS: 00010a47 RAX: 93dd86875b893714 RBX: ffffc900140db000 RCX: 000000008f1809f4 RDX: 000000008f1809db RSI: 000000003b9aca00 RDI: ffffc900140db000 RBP: ffff8800c68c9bb8 R08: 0000000000000002 R09: 00000029c96d9833 R10: 0000000020000000 R11: 000000704d65e9b4 R12: ffffc900140c0000 R13: ffffc900140db000 R14: ffffc900140c0000 R15: 000000000000006e FS: 00007fb403d3b710(0000) GS:ffffc90000400000(0000) knlGS:00000000f77538e0 CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033 CR2: 0000000000aefe18 CR3: 0000000231861000 CR4: 00000000000006e0 DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000 DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400 Process VirtualBox (pid: 7115, threadinfo ffff8800c68c8000, task ffff8801000f5e00) Stack:

ffffc900140db000 ffffc900140db980 ffff8800c68c9bd8 ffffffffa0c649f4

<0> ffffc9001409a000 ffffc900140db780 ffff8800c68c9d28 ffffffffa0c5a682 <0> ffff8800c68c9dd8 00000000000000b1 ffffffff000000ff ffff880000000001 Call Trace:

[<ffffffffa0c649f4>] g_abExecMemory+0x14c34/0x180000 [vboxdrv] [<ffffffffa0c5a682>] g_abExecMemory+0xa8c2/0x180000 [vboxdrv] [<ffffffff810c27e0>] ? generic_file_aio_write_nolock+0x251/0x286 [<ffffffffa0c5718d>] g_abExecMemory+0x73cd/0x180000 [vboxdrv] [<ffffffffa0c932f7>] g_abExecMemory+0x43537/0x180000 [vboxdrv] [<ffffffffa0c6178b>] g_abExecMemory+0x119cb/0x180000 [vboxdrv] [<ffffffffa0c3d6dd>] supdrvIOCtlFast+0x44/0x56 [vboxdrv] [<ffffffffa0c3d160>] VBoxDrvLinuxIOCtl+0x44/0x1a3 [vboxdrv] [<ffffffff81108c78>] vfs_ioctl+0x22/0x87 [<ffffffff811091d4>] do_vfs_ioctl+0x47b/0x4c1 [<ffffffff81109270>] sys_ioctl+0x56/0x79 [<ffffffff81011cf2>] system_call_fastpath+0x16/0x1b

Code: 00 eb bc 90 be 01 00 00 00 4c 89 e7 e8 d3 0e 00 00 48 3d 00 ca 9a 3b 74 e1 41 8b 8c 24 d0 84 00 00 31 d2 be 00 ca 9a 3b 48 f7 e1 <48> f7 f6 eb ca 48 8b 87 90 28 00 00 eb 9d 66 66 2e 0f 1f 84 00 RIP [<ffffffffa0c91447>] g_abExecMemory+0x41687/0x180000 [vboxdrv]

RSP <ffff8800c68c9ba8>

---[ end trace c78074dda487755b ]---

Change History

comment:1 Changed 4 years ago by frank

Please could you attach the complete kernel log? So far we were not able to reproduce this problem.

comment:2 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use