VirtualBox

Ticket #6027 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

VirtualBox is not restoring my saved machine state for Windows 7 Host, ArchLinux Guest

Reported by: sathyabhat Owned by:
Priority: major Component: other
Version: VirtualBox 3.1.2 Keywords: restore save machine state
Cc: Guest type: Linux
Host type: Windows

Description

I'm using VirtualBox 3.1.2 (on Windows 7, as my host OS) to experiment with an ArchLinux install. I use the Save Machine State option when powering down my VM so that it can be restored as it was. If I try to restore it immediately, without closing VirtualBox, the restore state works fine. However if I attempt to do the same after closing VirtualBox GUI, on launching VirtualBox, VirtualBox behaves as if the machine state was never saved, and starts the VM akin to a cold-boot.

All changes made to my had disk do remain - just that the Save previous state feature does not work - it doesn't restore the VM to the state it was saved, rather it acts as the system was switched off.

Attachments

VBox.log Download (62.8 KB) - added by sathyabhat 4 years ago.
VBox.log.1 Download (59.3 KB) - added by sathyabhat 4 years ago.

Change History

Changed 4 years ago by sathyabhat

Changed 4 years ago by sathyabhat

comment:1 Changed 4 years ago by hasinasi

Is this by any chance related to this:  http://forums.virtualbox.org/viewtopic.php?f=1&t=26340&p=121027&hilit=saved#p121027

In my case (kubuntu 9.10-32bit host, VB 3.1.2), this did the trick.

comment:2 Changed 4 years ago by sathyabhat

@hasinasi : Indeed, I have installed VirtualBox at a nonstandard location as well. Thanks for the pointer.

comment:3 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #5656

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use