VirtualBox

Ticket #602 (closed defect: fixed)

Opened 7 years ago

Last modified 6 years ago

VirtualBox 16-bit color rendering incorrect (Lycoris)

Reported by: Technologov Owned by:
Priority: major Component: other
Version: Keywords:
Cc: Guest type: other
Host type: other

Description

Host: Windows XP SP2, Athlon XP, VBox 1.5.0.

Guest: Lycoris 1.4 Linux.

VirtualBox renders some 16-bit(?) pictures incorrectly. After bootong Lycoris 1.4 under VirtualBox and VirtualPC, the difference is huge. Please take a look at your color/palette conversion tables please.

I think the guest is in 16-bit color mode, because VirtualBox reported me a message saying this. However other guests doesn't seem to have such problems. Why ? Are there multiple 16-bit color modes ?

Screenshots attached. The bad one made with VirtualBox 1.5.0 and the good one made with MS Virtual PC.

-Technologov. 01.09.2007.

Attachments

lycoris-correct-color.PNG Download (38.5 KB) - added by Technologov 7 years ago.
lycoris-correct-color.PNG screenshot made with MS Virtual PC.
lycoris-incorrect-color.PNG Download (34.8 KB) - added by Technologov 7 years ago.
lycoris-incorrect-color.PNG screenshot made with VirtualBox 1.5.0.
mandrake-incorrect-color.PNG Download (26.6 KB) - added by Technologov 7 years ago.
mandrake-incorrect-color.PNG screenshot made with VirtualBox 1.5.0.
Lycoris-2007-09-01-21-22-43.log Download (37.9 KB) - added by Technologov 7 years ago.
Lycoris-2007-09-01-21-22-43.log

Change History

Changed 7 years ago by Technologov

lycoris-correct-color.PNG screenshot made with MS Virtual PC.

Changed 7 years ago by Technologov

lycoris-incorrect-color.PNG screenshot made with VirtualBox 1.5.0.

comment:1 Changed 7 years ago by Technologov

Well, I have done some additional testing with Mandrake 10.1 guest this time, and found out, that 15-bit, 16-bit and 24-bit at both 640x480 and 800x600 resoltions work correctly.

The only color mode that works incorrectly was 8-bit mode (256 colors) - palettes TOTALLY incorrect.

What's worse, is that while 16-bit and 24-bit modes were reported by VirtualBox, 15-bit and 8-bit modes were NOT.

So this problem may actually have something to do with 256-color mode, not 16-bit as stated before.

-Technologov

Changed 7 years ago by Technologov

mandrake-incorrect-color.PNG screenshot made with VirtualBox 1.5.0.

comment:2 Changed 7 years ago by frank

Please attach a guest log here.

Changed 7 years ago by Technologov

Lycoris-2007-09-01-21-22-43.log

comment:3 Changed 6 years ago by Technologov

This bug is about 256-color mode, which is fixed in 1.5.2. Please close this bug.

comment:4 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use