VirtualBox

Ticket #6006 (closed defect: obsolete)

Opened 7 years ago

Last modified 11 months ago

DNS not working Windows 7 host, Opensolaris guest Bridged network

Reported by: gganote Owned by:
Priority: major Component: network
Version: VirtualBox 3.1.2 Keywords: bridged network DNS
Cc: gganote@… Guest type: Solaris
Host type: Windows

Description (last modified by vushakov) (diff)

The host is Windows 7 professional 64 bit. The guest is OpenSolaris, specifically Nexenta 3.0 alpha 3.

The dns is configured properly, with DHCP, and is getting an IP, and all the DNS settings are getting configured properly as well.

I also have a Nexenta 2.2 commercial storage appliance configured for static IP, and DNS is not resolving on this box, either.

The host is a laptop, and the network is my wireless card.

Any ideas hear?

Thanks

Change History

comment:1 Changed 7 years ago by ghutch

I am seeing the same problem. Have reported it as  http://www.virtualbox.org/ticket/5890 back in 2009. I have not heard much back about it yet. :-(

comment:2 Changed 16 months ago by vushakov

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)

No evidence that it's a duplicate of #5890, so can't close as duplicate in good conscience. Bridging to WiFi might have been a factor too. Without any further details no point in keeping this open.

comment:3 Changed 11 months ago by AbsaLootly

  • Status changed from closed to reopened
  • Resolution obsolete deleted

I am running VirtualBox 5.0.2, on a Windows 7 64 bit host, with an Ubuntu 14.04 server VM. The server can access the internet and DNS in NAT mode but not in bridged mode. The only issue with the bridged mode is that the DNS is not working. If I ping google.com from the host and get an IP address then the VM can ping the address but not google.com

I am trying to set up a simple LAMP stack and I need a set IP Address for my development work. NAT does not provide the set IP address as it is setup for DHCP when in NAT mode.

I am able to look at the resolve.conf file and see that it is currently setup to use two google DNS lookup servers as follows:

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 8.8.8.8
nameserver 8.8.4.4

This means the the DNS should already be trying to use the google DNS lookups yet it still fails.

I know that there is no issue with the firewall as it has been turned off yet the problem remains.

Any help would be greatly appreciated!

Last edited 11 months ago by vushakov (previous) (diff)

comment:4 Changed 11 months ago by vushakov

  • Status changed from reopened to closed
  • Resolution set to obsolete

Please, don't reopen old bugs that are superficially similar. Please file a new bug. As Bugtracker guidelines ask, please provide at least the VBox.log file for the VM.

Are you bridging to a wired or to a wireless card on the host?

How is networking configured in the guest? Static, DHCP?

Can you provide a packet trace captured in the guest that demonstrates your problem? Say, a ping by the IP address and a ping by name?

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use