VirtualBox

Ticket #5985 (closed defect: wontfix)

Opened 4 years ago

Last modified 4 years ago

VBox fails to load XP saved state after update from 3.0.8 to 3.1.2 on Karmic.

Reported by: JendaV Owned by:
Priority: major Component: other
Version: VirtualBox 3.1.2 Keywords: saved state
Cc: Guest type: Windows
Host type: Linux

Description

After using aptitude to update from 3.0.8 to 3.1.2, the Windows XP saved state doesn't load with an error message that can be seen in the VBox.log.

If it is related, just before the update, seamless mode in Vbox stopped working (the windows desktop remains in place and Gnome panels are greyed out (completely, not faded)) and the clipboards of the two systems ceased to be connected as well.

Attachments

VBox.log Download (43.8 KB) - added by JendaV 4 years ago.

Change History

Changed 4 years ago by JendaV

comment:1 Changed 4 years ago by hasinasi

Is this by any chance related to this:  http://forums.virtualbox.org/viewtopic.php?f=1&t=26340&p=121027&hilit=saved#p121027

In my case (kubuntu 9.10-32bit host, VB 3.1.2), this did the trick.

comment:2 Changed 4 years ago by sandervl73

It's a different problem.

comment:3 Changed 4 years ago by sandervl73

Your 3.0.8 installation was OSE and 3.1.2 is PUEL (our binary distribution)?

comment:4 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to wontfix

Due to differences between OSE and PUEL (in this case the PXE BIOS) you can't share saved states between the two.

comment:5 Changed 4 years ago by bird

  • Summary changed from Vbox fails to load XP saved state after update from 3.0.8 to 3.1.2 on Karmic. to VBox fails to load XP saved state after update from 3.0.8 to 3.1.2 on Karmic.

The problem is that the PXE ROM image that OSE uses (Net Boot) is smaller than the one we use in the PUEL version (intel). The page manage (PGM) component cannot handle this and thus aborts the restoring of the saved state.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use