VirtualBox

Opened 15 years ago

Closed 15 years ago

#5983 closed defect (invalid)

Cannot mount NFS share on guest from the Ubuntu NFS server on host

Reported by: axos88 Owned by:
Component: network/NAT Version: VirtualBox 3.1.2
Keywords: nfs ubuntu windows xp nat client unix services Cc:
Guest type: Windows Host type: Linux

Description

I tried to get NFS mounts to work on Ubuntu 9.10 host, and Windows XP guest. The host serves as the NFS server, and the guest should be the NFS client, using microsoft client services for unix.

There are a few reasons I would like to avoid using samba.

Configuration on host:

/etc/exports:

/home/akos 10.0.2.0/24(rw,sync,no_subtree_check)

ping 10.0.2.101 will not work...

Configuration on guest:

Network adapter 1 in NAT mode. ping 192.168.2.2 works ipconfig return ip address 10.0.2.101 Trying to connect to share \10.0.2.2\home\akos

The error message is not very helpful "An unexpected error has occured".

I talked to one of the guys in #virtualbox, he checked things, and said this was a bug in NFS support, and said that I should file a bug report, so I did.

Attachments (1)

VBox.log (68.9 KB ) - added by axos88 15 years ago.

Download all attachments as: .zip

Change History (7)

by axos88, 15 years ago

Attachment: VBox.log added

comment:1 by Frank Mehnert, 15 years ago

Well, your guest is behind NAT, therefore it wouldn't be accessible from the host and therefore ping wouldn't work of course. The correct setting for /etc/exports on the host is

127.0.0.1/24(rw,sync,no_subtree_check)

comment:2 by vasily Levchenko, 15 years ago

Right, I've advised to rise this ticket because I've met similar problem discussed on forum and add to todo investigation if it possible to add to NAT some ability to detect and open right ports automatically. According to major resources I've browsed recently this mostly related to Ubuntu hosts and some manual security settings. Trying several NFS servers (not all ofc) I've found that only Ubuntu ones have got such problems with default configuration.

comment:3 by vasily Levchenko, 15 years ago

Summary: Cannot mount NFS share on guest from the NFS server on hostCannot mount NFS share on guest from the Ubuntu NFS server on host

comment:4 by axos88, 15 years ago

I have solved the issue, windows SFU opens unprivilidged ports, and the NFS server does not like this. Need to add (insecure) option to exports, afterwards it works fine.

Also need to export to ip 127.0.0.1, and from the guest side need to access 10.0.2.2 (kinda confusing, but logical)

comment:5 by vasily Levchenko, 15 years ago

thanks for update.

comment:6 by vasily Levchenko, 15 years ago

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use