VirtualBox

Opened 15 years ago

Closed 14 years ago

#5966 closed defect (fixed)

Remote Desktop to Windows 2000 guest causes uncontrollable memory usage => Fixed in SVN

Reported by: cpuprocess Owned by:
Component: RDP Version: VirtualBox 3.1.2
Keywords: Windows, RDP, remote, memory Cc:
Guest type: Windows Host type: Windows

Description

When I tried to connect from a remote Windows 2000 Professional system to a Windows 2000 RTM guest running on XP Home Build 2600 SP3 host with no authentication, memory usage goes from about 50MB to over 1GB. VirtualBox v3.0.8 doesn't seem to have this problem. The host system has 2GB of memory, and the guest is configured for 256MB of memory. Thank you for your time to try to resolve this problem.

Attachments (7)

VBox.log (41.4 KB ) - added by cpuprocess 15 years ago.
vboxbug.JPG (240.2 KB ) - added by cpuprocess 15 years ago.
The Runaway Memory Usage
VBoxNoVRDPused.log (57.0 KB ) - added by cpuprocess 15 years ago.
VBoxXP.log (58.7 KB ) - added by cpuprocess 15 years ago.
vboxbugxp.JPG (256.5 KB ) - added by cpuprocess 15 years ago.
combos_and_log_extract.txt (1.3 KB ) - added by Patrick 14 years ago.
sorry last 2 paragraphs formatted properly
monitored_host_mem_usage.txt (786 bytes ) - added by Patrick 14 years ago.
a log showing memory usage and leak on host

Download all attachments as: .zip

Change History (14)

comment:1 by sunlover, 15 years ago

Please attach VBox.log of the Windows 2000 VM.

by cpuprocess, 15 years ago

Attachment: VBox.log added

comment:2 by cpuprocess, 15 years ago

When I connected from a remote Windows 2000 Professional system to a Windows 2000 RTM guest running on XP Home Build 2600 SP3 host with no authentication and tried to run Happy Aquarium on Facebook, memory usage goes from about 50MB, which is normal on my system, to over 1GB. VirtualBox v3.0.8 doesn't seem to have this problem. The host system has 2GB of memory, and the guest is configured for 256MB of memory. Thank you for your time to try to resolve this problem.

by cpuprocess, 15 years ago

Attachment: vboxbug.JPG added

The Runaway Memory Usage

comment:3 by sunlover, 15 years ago

Thanks for the log file.

What happens if you disable VRDP for the VM and then run the Windows 2000 guest with Happy Aquarium? Do you still see the memory leak?

BTW what is the URL for Happy Aquarium?

comment:4 by cpuprocess, 15 years ago

When I connect "remotely" to the VM using the Remote Desktop Connection bundled with the XP host, I see a smaller memory leak; I have attached the log for this trial in VBoxXP.log, and a screenshot of the memory usage. When I don't use VRDP, whether it is enabled or not, there appears to be no memory leak; I have attached the log for this trial in VBoxNoVRDPused.log.

The URL for Happy Aquarium is: http://apps.facebook.com/happy-aquarium/

by cpuprocess, 15 years ago

Attachment: VBoxNoVRDPused.log added

by cpuprocess, 15 years ago

Attachment: VBoxXP.log added

by cpuprocess, 15 years ago

Attachment: vboxbugxp.JPG added

comment:5 by Patrick, 14 years ago

I see memory leakage on host (VBoxSDL/VirtualBoxVM process) at a rate of a few megabytes per minute whenever Remote Desktop Connections are active and the display is changing (video, animated gifs etc). When the screen is static or there is no active Remote Desktop Connection no further leakage occurs. At no stage does the memory appear to get released while the Virtual Machine is active. Analysis of memory usage within the guest OS shows it isn't being allocated there.

Combinations where problem confirmed:- Host: Debian squeeze running vbox 3.1.6, 3.2.6, 3.2.8 , Guest: Ubuntu 10.4 Host: Mac OS X 10.6.4 vbox 3.2.8, Guest: Ubuntu 10.4 Host: Mac OS X 10.6.4 vbox 3.2.8, Guest: Windows XP Pro Host: Windows XP Pro vbox 3.2.8, Guest: Ubuntu 10.4 CD in 'try/demo' mode (here I used all the default options when creating the VM) Host: Windows XP Pro vbox 3.2.8, Guest: Windows XP Pro

If left long enough the VM fails with this log 19:23:12.241 PGM: Failed to procure handy pages; rc=VERR_NO_MEMORY rcAlloc=VERR_NO_MEMORY rcSeed=VINF_SUCCESS cHandyPages=0x10 19:23:12.241 cAllPages=0x484cf cPrivatePages=0x2cf43 cSharedPages=0x0 cZeroPages=0x1b58c 19:23:12.242 PGM: Failed to procure handy pages; rc=VERR_NO_MEMORY rcAlloc=VERR_NO_MEMORY rcSeed=VINF_SUCCESS cHandyPages=0x10 19:23:12.242 cAllPages=0x484cf cPrivatePages=0x2cf43 cSharedPages=0x0 cZeroPages=0x1b58c 19:23:12.243 VM: Raising runtime error 'HostMemoryLow' (fFlags=0x2) 19:23:12.243 Changing the VM state from 'RUNNING' to 'SUSPENDING'. 19:23:12.292 Changing the VM state from 'SUSPENDING' to 'SUSPENDED'. 19:23:12.293 Console: VM runtime error: fatal=false, errorID=HostMemoryLow message="Unable to allocate and lock memory. The virtual machine will be paused. Please close applications to free up memory or close the VM"

Seems to be a general problem here with the RDP service, can anyone else confirm?

by Patrick, 14 years ago

Attachment: combos_and_log_extract.txt added

sorry last 2 paragraphs formatted properly

by Patrick, 14 years ago

a log showing memory usage and leak on host

comment:6 by Frank Mehnert, 14 years ago

Summary: Remote Desktop to Windows 2000 guest causes uncontrollable memory usageRemote Desktop to Windows 2000 guest causes uncontrollable memory usage => Fixed in SVN

We believe that we found the memory leak. The fix will be contained in the next maintenance release.

comment:7 by Sander van Leeuwen, 14 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use