VirtualBox

Ticket #5961 (closed defect: obsolete)

Opened 4 years ago

Last modified 4 months ago

VBoxManage hangs on futex wait

Reported by: joe42 Owned by:
Priority: major Component: VM control
Version: VirtualBox 3.2.6 Keywords: futex hang lockup
Cc: Guest type: other
Host type: Linux

Description (last modified by frank) (diff)

I have an automated system which keeps about four VirtualBox guests (various guest operating systems) running. Each guest runs for a few hours - when it shuts down, the driver script uses VBoxManage to destroy the VM, import and configure a new one and finally start the newly imported VM. The driver script also uses VBoxManage to query the status of running VMs (list runningvms, showvminfo etc.).

Every now and then (a few times a week) I end up having VBoxManage processes hanging doing nothing. They appear to be frozen - output from 'top' claims they sleep on the futex_wait channel.

If I run a "VBoxManage list vms" manually (or any other VBoxManage command that interacts with the virtual machines), it too will just hang indefinitely.

My guess is that the VBoxManage commands all talk to the same common daemon (VBoxSVC?), and that this daemon somehow doesn't respond. But I have no way of debugging this any further.

Is there anything I can do to help resolve this issue? Does VBoxSVC log information somewhere I didn't see? Would it be helpful with an strace/backtrace/...? Is anyone else seeing this issue?

The host system is Debian Lenny (linux 2.6.26-2-amd64); I also a parallel VB setup on Solaris where this problem never occurs (Solaris doesn't have futexes of course).

Attachments

stracelog.tar.bz2 Download (191.3 KB) - added by rcarz 3 years ago.

Change History

comment:1 Changed 4 years ago by frank

Right, it is possible that the VBoxSVC process is hanging. When you are able to reproduce such a hang it would be helpful if you could make VBox create a  core dump -- most probably you have to force VBoxSVC to dump the core, see the link. If you can provide a core dump please contact me via frank _dot_ mehnert _at_ sun _dot_ com so I can tell you a server where you can upload the core dump. Thank you!

comment:2 Changed 4 years ago by frank

Thanks for the core dumps to both users. Looking at the core dump of Jakob we saw a quite complex situation and there is indeed a locking problem in VBoxSVC. It is likely that we fixed this issue in the current SVN trunk but the fix is too intrusive to backport to the VBox 3.1 branch. So I fear we will not fix this not before the next new major release.

comment:3 Changed 4 years ago by rcarz

I seem to also be having this issue on 3.2.6. I am unable to start VirtualBox (it hangs) and attempts to kill VBoxSVC always end in a zombie process. I have to reboot before it'll start again. If I attach to the VBoxSVC process with strace, all I see it the futex_wait.

The host system is Linux (2.6.32-gentoo-r7). I've tried compiling from source and the binary distribution and both show the same behaviour.

comment:4 Changed 4 years ago by frank

  • Version changed from VirtualBox 3.1.2 to VirtualBox 3.2.6

Changed 3 years ago by rcarz

comment:5 Changed 3 years ago by rcarz

This seems to happen after VMs have been running for weeks. I attached a log output from strace.

app-emulation/virtualbox-bin-3.2.12-r1

Linux tiger 2.6.34-gentoo-r1 #6 SMP Sat Oct 9 12:10:19 PDT 2010 i686 Intel(R) Core(TM)2 Quad CPU Q6600 @ 2.40GHz GenuineIntel GNU/Linux

comment:6 Changed 4 months ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use