VirtualBox

Ticket #5949 (closed defect: fixed)

Opened 4 years ago

Last modified 2 years ago

Bridged networking broken in Virtualbox 3.1.2 for Windows 2003 R2 host (similar: Ticket #5924)

Reported by: maxim.f Owned by:
Priority: critical Component: network
Version: VirtualBox 3.1.2 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

After upgrading from VirtualBox 3.1.0 to 3.1.2 (no further system changes) the bridged network has broken.

Related:
Ticket #5924 seems to describe exactly the same problem for Windows 2008 R2 host.

Config:
Host: Windows 2003 R2 (x64)
Guest: Windows XP SP3 (x86)

Problem:
After the mentioned update the guest still has full (working) access to the internal network (192.168.x.x). If trying to access the internet the guest displays messages saying the computer would have no internet connection.

  • Trying to load a website from the guest fails although the same website loads perfectly from any other (real) computer from the internal network (or from the host)
  • Pinging a website from the guest yields 50% packet-loss, while being 100% accessible from any other PC from the internal network (or from the host)

Change History

comment:1 Changed 4 years ago by maxim.f

Sorry, I have to correct myself: The right version I was upgrading from is 3.0.12.

comment:2 Changed 4 years ago by misha

What third-party networking-related software (like VPN, Antivirus, Firewall or virtualization software) do you have installed on your host?

comment:3 Changed 4 years ago by maxim.f

Following software is running on my host:

  • Routing and RAS service (RRAS)

This service has not changed since VirtualBox 2.x times.

  • The antivirus I have running there has all network, mail and real-time modules disabled. I use it solely to inspect suspicious files from explorer's context menu.

There it is. I have no VPNs, no firewall (beyond RRAS), no virtualization software or anything similar running on the host OS.

...and like I said: nothing has changed, except upgrading to VirtualBox 3.1.2 from 3.0.12

comment:4 Changed 4 years ago by misha

I'm asking because the problem might be caused by some system re-config during the install. Does downgrading back to 3.0.12 solves your issue?

comment:5 Changed 4 years ago by maxim.f

Sorry, but I cannot downgrade back to 3.0.12 anymore. After reading ticket #5924 I decided to completely restore the host and the guest from a back-up still using 3.0.12. :-(
Only in case it's really, really important and really, really necessary I could upgrade to 3.1.2 again and then downgrade back to 3.0.12.

comment:6 Changed 4 years ago by ddn

have seen this on my Windows 2008 32bit host (prev win version). i think it is related to vbox drivers don't understand how to work with RRAS role installed. (there are virtual VPN interfaces in RRAS).

comment:7 Changed 4 years ago by maxim.f

Still experiencing the same problems with VirtualBox 3.1.4. Rolled back using a backup to 3.0.12 once again.

comment:8 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 4.1.6.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use