VirtualBox

Opened 15 years ago

Closed 15 years ago

#5937 closed defect (worksforme)

Red Hat install VirtualBox error: vboxdrv.ko Invalid module format

Reported by: Leonardo Owned by:
Component: installer Version: VirtualBox 3.1.2
Keywords: Cc:
Guest type: other Host type: Linux

Description

Hi

I tried install the VirtualBox (VirtualBox-3.1-3.1.2_56127_rhel4-1.i386.rpm ), but failed

ERROR:


[root@cc etc]# /etc/init.d/vboxdrv setup Stopping VirtualBox kernel module [ OK ] Removing old VirtualBox netadp kernel module [ OK ] Removing old VirtualBox netflt kernel module [ OK ] Removing old VirtualBox kernel module [ OK ] Recompiling VirtualBox kernel module [ OK ] Starting VirtualBox kernel module [FAILED]

(modprobe vboxdrv failed. Please use 'dmesg' to find out why)


Dmesg message:


vboxdrv: disagrees about version of symbol struct_module


I did try force the instalation of vboxdrv


/sbin/modprobe vboxdrv FATAL: Error inserting vboxdrv (/lib/modules/2.6.9-78.0.17.ELsmp/kernel/misc/vboxdrv.ko): Invalid module format


My host system is:


Red Hat Enterprise Linux ES release 4 (Nahant Update 7) 32B uname -r 2.6.9-78.0.17.ELsmp


I also instaled the dkms package, and all gcc software are the same version of kernel build.

So I need help to solve this issue.

Attachments (1)

vbox-install.log (6.9 KB ) - added by Leonardo 15 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 by Frank Mehnert, 15 years ago

Please attach the file /var/log/vbox-install.log (use the Attach button!)

by Leonardo, 15 years ago

Attachment: vbox-install.log added

comment:2 by Frank Mehnert, 15 years ago

I'm not sure but your dkms installation seems to be a bit broken. What is the output of

dkms status

?

comment:3 by Leonardo, 15 years ago

Hi frank.

I fix the problem. When I install the package kernel-smp-devel, and re-run /etc/init.d/vboxdrv setup Must be the same version of the kernel.

I guess that the error in dkms package, isn't important, because the virtualbox must install without this.I just instaled, because I didn't know the cause of the errors (Invalid module format).

My suggetion to developer group, is make a pre-requirement when run the install of Virtual Box. Like:

Check supported kernell Check if the version of gcc was the same that the kernel was buid. Check if there is packages kernel-devel. Check if the /usr/src/kernel/<kernel> is correct.. in the right place.

I spend 2 day to install the virtualbox, because I needed discover whta was wrong.

comment:4 by Frank Mehnert, 15 years ago

Resolution: worksforme
Status: newclosed

These checks are quite difficult, especially the check for the correct gcc version. The documentation clearly states that the correct kernel sources must be installed to compile the VBox kernel modules.

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use