VirtualBox

Opened 15 years ago

Closed 8 years ago

#5908 closed defect (obsolete)

Exiting Seamless mode with KDE4 compositing doesn't restore guest desktop

Reported by: Joseph Reagle Owned by:
Component: GUI/seamless Version: VirtualBox 3.1.2
Keywords: Cc:
Guest type: Windows Host type: Linux

Description

I'm running KDE4.3.4 on Karmic 9.10 with an XP guest. When I go into seamless mode, there is an thin fuzzy margin of the XP desktop on the left of guest windows, which I presume is some sort of artifact from composite shadows. Worse, though, is when I try to exit seamless mode, I am left with a fuzzy dark translucent square roughly the size of the guest window, but which doesn't show the guest desktop and applications -- except for a region previously occupied by a window in seamless mode.

Change History (6)

comment:1 by theboxman, 15 years ago

I have the exact same issue on Mandriva2010.0. KDE4.3.4 with compositing enabled. I managed to exit seamless mode (a bit tricky, you have to shutdown windows, when you only see a very small portion of the screen). Then the setting is saved, and on restart everything is fine again. This bug is severe in my opinion, because it messes with the compositing, and I had a lot of crashes while doing different stuff and having VB running in the background, at first I didn't know this constant X crashes were related to this seamless issue. Let me repeat, this issue WILL crash X.

comment:2 by hasinasi, 15 years ago

Same here on KDE 4.3.4. Very annoying. Big problem. Has been around for many versions. Possibly a KDE/kwin issue?

comment:3 by hasinasi, 15 years ago

Just confirmed that it's still there in KDE 4.4 RC2

comment:4 by aeichner, 8 years ago

Resolution: fixed
Status: newclosed

Please reopen if this is still a problem with a recent VirtualBox release.

comment:5 by aeichner, 8 years ago

Resolution: fixed
Status: closedreopened

comment:6 by aeichner, 8 years ago

Resolution: obsolete
Status: reopenedclosed
Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use