VirtualBox

Ticket #5905 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

Copy and Paste using Mouse in VM Description Crashes VirtualBox GUI

Reported by: Ramzee Owned by:
Priority: minor Component: GUI
Version: VirtualBox 3.1.2 Keywords: Settings Description Edit Copy Paste
Cc: Guest type: Windows
Host type: Windows

Description

Detailed Description 1) Start Virtual Box 2) Click on the Descriptions Tab of a Powered Off VM. 3) Click on the Edit Button 4) This opens the Settings window at the Description tab. 5) Select some text and copy it using the right click mouse menu. 6) Right click as if you were to past using the mouse again or use Ctrl+V. 6) The mouse icon changes to Busy and the Window Title changes to Settings (Not Responding). 7)Closing the Settings Window generates the Windows 7 message "VirtualBox GUI is not responding" 8)Choosing to Close the program both the Settings and VirtualBox GUI Windows close. 9) Starting VirtualBox again the status of the VM is changed to Aborted.

NOTE: Copy and Past using the keyboard (ie Shift+ Right Arrow, Ctrl+C, Ctrl+V) is ok and if you copy with the keyboard you can past with the mouse without issue. It only fails when you copy with the mouse and then try to past the contents of the clipboard.

This Windows 7 log is from 3.0.12 (due to a bridge networking issue in 3.1.2) but 3.1.2 exhibits the same behaviour.

Description:

A problem caused this program to stop interacting with Windows.

Problem signature:

Problem Event Name: AppHangB1 Application Name: VirtualBox.exe Application Version: 3.0.12.0 Application Timestamp: 4af9712f Hang Signature: f01a Hang Type: 8 OS Version: 6.1.7600.2.0.0.256.48 Locale ID: 2057 Additional Hang Signature 1: f01ae093d349f57fdb2079d35ea8b722 Additional Hang Signature 2: ee77 Additional Hang Signature 3: ee77dd5e02954bb096e0bef0315cb698 Additional Hang Signature 4: 7de1 Additional Hang Signature 5: 7de15a85790e084aabc0146071d6ad78 Additional Hang Signature 6: e934 Additional Hang Signature 7: e934ebf59ab07661ec2b1c122d3048bc

VirtualBox 3.0.12, 3.1.2 Host: i7, Windows 7 Pro (32 bit) Guests: All (as GUI related)

Change History

comment:1 Changed 4 years ago by Technologov

Duplicate of #4491.

-Technologov

comment:2 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use