VirtualBox

Ticket #590 (closed defect: fixed)

Opened 7 years ago

Last modified 6 years ago

NT 4.0 installation of guest additions fails

Reported by: fbusse Owned by:
Priority: critical Component: other
Version: VirtualBox 1.4.0 Keywords: nt4 additions
Cc: Guest type: other
Host type: other

Description

After successful (minimal) installation of german language Microsoft Windows NT 4.0 (tried both with SP 1 and SP 6.0a) I call the VB "guest additions" install. The additions install without error until the request for manual or automatic reboot. Instead of reboot, their installer comes up again. In a first try, I've followed the installer once more, seeming to install (again) with no error, in a second try, I've cancelled this second installer.

In both cases, after installation of the "guest additions", booting fails with the message "Starting at least one service failed, which should start with system startup. Please check the event protocol" (translation of german message as in  screenshot).

In this state, the VM seems not to recognize any keyboard stroke, no mouse is displayed. Even sending [Ctrl]-[Alt]-[Del] from the VB menu has no effect. The only way to escape seems a brute force power-down. On next startup of the VM, the same issue...

Requests both  in the forum and  in the mailing-list did not bring up any solution.

Change History

comment:1 Changed 7 years ago by Technologov

Bug verified.

I experience the same. After installing guest additions on English NT4 (SP0 or SP6a), and restarting, I cannot login to the NT machine.

-Technologov. 30.08.2007.

comment:2 follow-up: ↓ 14 Changed 7 years ago by fbusse

Adding information on environment: Host is a Compaq nc4200 notebook running Kubuntu Feisty with current updates (2.6.20-16-generic), VB is 1.5.0-24069_Ubuntu_feisty.

comment:3 follow-up: ↓ 4 Changed 7 years ago by sandervl73

Please verify that the installed drivers and executables are indeed all up-to-date. (\windows\system32\vbox* & \windows\system32\drivers\vbox*)

comment:4 in reply to: ↑ 3 Changed 7 years ago by fbusse

Replying to sandervl73:

Please verify that the installed drivers and executables are indeed all up-to-date. (\windows\system32\vbox* & \windows\system32\drivers\vbox*)

Pls ack that you are suspecting some VB special drivers not to be up-to-date within the NT guest after installing the additions. I will then try to access the VDI and check from another NT virtual machine this eve.

Would be kinda helpful to know in detail, which files to check, how to check the same and which should be the outcome of the checks in case they were up-to-date.

comment:5 follow-ups: ↓ 6 ↓ 10 Changed 7 years ago by sandervl73

Additions imply inside the guest. Please check all vbox* files in the directories mentioned above and compare them to the files in the driver directory on the additions iso. All dates & times should be identical.

comment:6 in reply to: ↑ 5 Changed 7 years ago by fbusse

Replying to sandervl73:

Thx for your advice, which I will be happy to follow this eve.

Additions imply inside the guest.

(Sometimes I'm sorry to be no  legilimens. So I missed the clue that you were talking about files related to the additions,  before. And I'm not familiar enough with the Windows VB host to know, if it might have VB related files in the directories you mentioned.)

comment:7 follow-up: ↓ 8 Changed 7 years ago by sandervl73

No problem, I see now that I wasn't very clear. :)

comment:8 in reply to: ↑ 7 Changed 7 years ago by fbusse

BTW, what would be the proper solution - apart from reporting here - if the files were not up-to-date? Just overwriting with the files from the iso?

comment:9 Changed 7 years ago by sandervl73

Exactly.

comment:10 in reply to: ↑ 5 ; follow-up: ↓ 13 Changed 7 years ago by fbusse

Replying to sandervl73:

Please check all vbox* files in the directories mentioned above and compare them to the files in the driver directory on the additions iso. All dates & times should be identical.

Only copies of some files from the iso in /driver/* seem to be on the crippled NT system in /winnt/system32 and /winnt/system32/drivers (not in /windows).

VBCoInst.dll, VBGuest.inf and VBoxMouse.inf from /driver/VBoxGuest, /driver/VBoxVideo/VBoxVideo.inf and /driver/VBoxSF/* are not in this tree (see  screenshot).

comment:11 Changed 7 years ago by fremsley

I managed to logon again after I had deactivated the mouse driver. After installing the guest additions (before reboot) I changed the registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\i8042prt\ImagePath

back to: "System32\DRIVERS\i8042prt.sys". However the system complaint (translation from German): 'The currently selected display driver can not be used. It is not available or not congigurated correctly. The System was started using the standard VGA driver ...'

comment:12 follow-up: ↓ 15 Changed 7 years ago by sandervl73

  • Priority changed from major to critical

comment:13 in reply to: ↑ 10 Changed 7 years ago by fbusse

Replying to fbusse:

Only copies of some files from the iso in /driver/* seem to be on the crippled NT system in /winnt/system32 and /winnt/system32/drivers (not in /windows).

VBCoInst.dll, VBGuest.inf and VBoxMouse.inf from /driver/VBoxGuest, /driver/VBoxVideo/VBoxVideo.inf and /driver/VBoxSF/* are not in this tree (see  screenshot).

Sander: Is there any advice to give after the above? Please comment.

comment:14 in reply to: ↑ 2 Changed 7 years ago by fbusse

Replying to fbusse:

VB is 1.5.0-24069_Ubuntu_feisty.

no change with todays current version 1.5.0-24069-1_Ubuntu_feisty

comment:15 in reply to: ↑ 12 ; follow-up: ↓ 16 Changed 7 years ago by igoddard

Replying to sandervl73: I installed NT4 sp1 and upgraded to sp6a into a newly installed VB 1.5. I didn't get any "service failed to start" messages but I got this display driver message at first and subsequent log-ons. I got the same looping on install guest additions. If I mount the additions ISO and use the display driver as a "have disk" driver it reports that the driver is installed but the error message comes up each time.

Upgrading to W2K as a test makes the system useable but as this was using a copy of W2K already in use it wouldn't be an acceptable work round. Platform is Kubuntu 6.06 on Core2 Duo (Advent laptop)

Ian

comment:16 in reply to: ↑ 15 Changed 7 years ago by igoddard

Replying to igoddard:

Replying to sandervl73: I installed NT4 sp1 and upgraded to sp6a into a newly installed VB 1.5. I didn't get any "service failed to start" messages but I got this display driver message at first and subsequent log-ons. I got the same looping on install guest additions. If I mount the additions ISO and use the display driver as a "have disk" driver it reports that the driver is installed but the error message comes up each time.

Upgrading to W2K as a test makes the system useable but as this was using a copy of W2K already in use it wouldn't be an acceptable work round. Platform is Kubuntu 6.06 on Core2 Duo (Advent laptop)

Ian

More info. I removed the VB installation and replaced it with 1.4. Installation of NT4 sp1 failed - either hung or complained about various setup files. I then saved the 1.4 additions iso and upgraded VB to latest. NT4 then installed and upgraded to sp6. Mounting 1.4 iso I was able to install the display driver which seems to be working. Mounting 1.5 iso & trying to install the driver from that brings up the message that the driver was compiled for an earlier version of Windows. Maybe this is the cause of the problems.

HTH

Ian

comment:17 follow-up: ↓ 18 Changed 7 years ago by gbuonfiglio

I have the same problem trying to install guest additions 1.5 on a Windows NT4 Server (installation "loop" and no video driver) but I was able to install the video drivers from VB 1.4. Guest screen resizing is not working but at least I have a working video. Mouse pointer integration looks fine also, and this one was ok since the first guest additions (VB 1.5) try.

comment:18 in reply to: ↑ 17 ; follow-up: ↓ 19 Changed 7 years ago by igoddard

Replying to gbuonfiglio:

Guest screen resizing is not working

This may be getting OT for the bug ticket and perhaps would be better on the regular forum but try allocating more video memory, e.g. 32Mb, in the machine config.

Ian

comment:19 in reply to: ↑ 18 ; follow-up: ↓ 20 Changed 7 years ago by arakula

Replying to igoddard:

Guest screen resizing is not working

This may be getting OT for the bug ticket and perhaps would be better on the regular forum but try allocating more video memory, e.g. 32Mb, in the machine config.

Won't change a thing, since this resizing stuff is a 1.5 addition, which wont work in the 1.4 guest additions, no matter how much video memory you add.

Presumably, this is also the change that prohibts using the 1.5 VGA driver in a Windows NT4 guest.

comment:20 in reply to: ↑ 19 Changed 7 years ago by igoddard

Replying to arakula:

Replying to igoddard:

Guest screen resizing is not working

This may be getting OT for the bug ticket and perhaps would be better on the regular forum but try allocating more video memory, e.g. 32Mb, in the machine config.

Won't change a thing, since this resizing stuff is a 1.5 addition, which wont work in the 1.4 guest additions, no matter how much video memory you add.

Presumably, this is also the change that prohibts using the 1.5 VGA driver in a Windows NT4 guest.

I read this as manual resizing via the Display properties applet. If the video memory is inadequate you may not be able to find the required mode in the Settings>List All Modes dialog.

comment:21 in reply to: ↑ description Changed 6 years ago by fbusse

Replying to fbusse:

after installation of the "guest additions", booting fails

Appears to be solved with 1.5.2-25433_Ubuntu_feisty.

Thx to the team!

comment:22 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Closing, please reopen if this problem still persists.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use