VirtualBox

Ticket #5885 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Bluescreen on Win 7-64 Host on shutdown after Virtual Box was being used (USB monitor) -> fixed in 3.1.4

Reported by: topse Owned by:
Priority: major Component: other
Version: VirtualBox 3.1.2 Keywords:
Cc: Guest type: other
Host type: other

Description

Hi, when I shutdown my Win-7-64 after having Virtual Box used in that session with a Win-XP-Guest, I get a bluescreen.

I have not found information about such a problem yet - is it new? Which additional information you need?

Best Regards,

Tobias

Attachments

VBox.log Download (63.6 KB) - added by topse 4 years ago.
Logfile from Virtual Machine which was used before Bluescreen

Change History

comment:1 Changed 4 years ago by frank

Problem unknown so far. Please start by attaching the VBox.log file of the VM you start before you shut down the host. I assume you shut down the host not before you terminated the VM?

Changed 4 years ago by topse

Logfile from Virtual Machine which was used before Bluescreen

comment:2 Changed 4 years ago by topse

Hi, I could reproduce the problem and have attached the VBox.log. Here a description what I have done:

  1. Boot my Computer with Win7-64
  2. Start VBox with WinXP Guest
  3. Used WinXP
  4. Shutdown WinXP-Guest
  5. Close VBox
  6. Shutdown Host-PC -> Bluescreen

Extremly annoying is that my VirtualBox.xml is destroyed on those crashes - so I always have to recreate my virtual machines because VBox has no possibility to load the machines (only the Harddrives I can reuse...).

I also have the Windows-Coredump, but I could not upload it because it's too big, so please find it here if needed:

 http://dl.dropbox.com/u/3600096/MEMORY.7z (File is still uploading - so please wait one hour from now... its around 60MB)

This problem occurs from time to time - today I had time myself so I could gather this data so send you...

Best Regards,

Tobias

comment:3 Changed 4 years ago by sandervl73

Use the sync tool from the sysinternals guys. It flushes the entire disk cache, which should prevent such issues when experimenting.

If you have installed the host interface and/or host internal drivers during VirtualBox installation, you might want to reinstall without those two. I'll check your system dump.

comment:4 Changed 4 years ago by sandervl73

  • Summary changed from Bluescreen on Win 7-64 Host on shutdown after Virtual Box was being used to Bluescreen on Win 7-64 Host on shutdown after Virtual Box was being used (USB monitor)

Our USB driver is in the call stack of the fault. Investigating.

comment:5 Changed 4 years ago by sandervl73

It's a conflict with the iLok USB driver.

comment:6 Changed 4 years ago by sandervl73

The problem should be fixed now. I'll post a link to a test build in a bit.

comment:8 Changed 4 years ago by topse

Hi Sander, I just got your messages and I am extensivly devastated. I will download the testbuild and install it. After that I will need some time to get the statistics about the situation. Maybe I come back in the first week of February?

Thanks for this incredible fast help!

Tobias

comment:9 Changed 4 years ago by sandervl73

Please check if 3.1.4 beta 1 solves the problem:  http://forums.virtualbox.org/viewtopic.php?f=15&t=27300

comment:10 Changed 4 years ago by topse

Hi, I have tested the Testbuild  http://www.virtualbox.org/download/testcase/VirtualBox-2010-01-22-15-13-38-win-3.1-rel-3.1.3-r56829-MultiArch.exe for 2 weeks now and the problem is definetly solved! I will install the 3.1.4 beta now.

Thanks for your help and Best Regards,

Tobias

comment:11 Changed 4 years ago by sandervl73

  • Summary changed from Bluescreen on Win 7-64 Host on shutdown after Virtual Box was being used (USB monitor) to Bluescreen on Win 7-64 Host on shutdown after Virtual Box was being used (USB monitor) -> fixed in 3.1.4

Thanks for your feedback.

comment:12 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use