VirtualBox

Ticket #5877 (closed defect: worksforme)

Opened 4 years ago

Last modified 16 months ago

Kernel driver not installed (rc=-1908) => Karmic upstart problem?

Reported by: m42h31 Owned by:
Priority: major Component: other
Version: VirtualBox 3.1.2 Keywords:
Cc: Guest type: other
Host type: other

Description (last modified by frank) (diff)

sudo /etc/init.d/vboxdrv setup this solution is work for me. But i got same error after rebooting my computer.

Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing

'/etc/init.d/vboxdrv setup'

as root. Users of Ubuntu, Fedora or Mandriva should install the DKMS package first. This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary.

Virtualbox says I need to /etc/init.d/vboxdrv setup again after reboot my computer :( :(, i'm using Ubuntu Karmic Koala kernel 2.6.31-17-generic. virtualbox version 3.1.2, I found the same problem on virtualbox 3.0.1.

Click to see the  screen shot

how to solve this ??

Attachments

vbox-install.log Download (4.1 KB) - added by m42h31 4 years ago.

Change History

comment:1 Changed 4 years ago by frank

  • Description modified (diff)

I've removed your log file. Please use the Attach File button to attach big files!

Please execute the command /etc/init.d/vboxdrv setup again and attach the content of /var/log/vbox-install.log!

comment:2 Changed 4 years ago by vsrao

not found

Changed 4 years ago by m42h31

comment:3 Changed 4 years ago by m42h31

ok.. i have attach installation log.. please check it.. :)

comment:4 Changed 4 years ago by frank

That log file looks correct. What is the output of

/sbin/lsmod | grep vbox

and

/bin/ls -l /dev/vboxdrv

?

comment:5 Changed 4 years ago by chris.gaeth

I am having the same issue. I went as far as wiping out and reloading Ubuntu 9.10 64-bit just make sure I had a clean install.

/sbin/lsmod | grep vbox vboxnetadp 6528 0 vboxnetflt 14288 2 vboxdrv 1777740 3 vboxnetadp,vboxnetflt

/bin/ls -l /dev/vb* crw------- 1 root vboxusers 10, 55 2010-01-05 08:08 /dev/vboxdrv crw-rw---- 1 root root 10, 54 2010-01-05 08:08 /dev/vboxnetctl

comment:6 Changed 4 years ago by frank

Thanks. Could you add the output of

cat /proc/misc | grep vbox

and

cat /proc/devices | grep vbox

as well?

comment:7 Changed 4 years ago by chris.gaeth

Here you go:

cat /proc/misc | grep vbox

54 vboxnetctl 55 vboxdrv

cat /proc/devices | grep vbox Produced nothing.

comment:8 Changed 4 years ago by m42h31

/sbin/lsmod |grep vbox vboxdrv 176360 1


/bin/ls -l /dev/vboxdrv crw------- 1 root root 10, 55 2010-01-06 09:44 /dev/vboxdrv


cat /proc/misc | grep vbox

55 vboxdrv


cat /proc/devices | grep vbox << no output

comment:9 Changed 4 years ago by chris.gaeth

Any updates?

comment:10 Changed 4 years ago by frank

  • Description modified (diff)

Actually I don't know why the kernel driver is not detected. I assume you are using the PUEL version of VirtualBox. Do I understand both of you correct that after /etc/init.d/vboxdrv setup, you can successfully use VirtualBox until the next reboot?

comment:11 Changed 4 years ago by m42h31

yes, after /etc/init.d/vboxdrv setup i can use virtualbox normally. but, after next reboot the virtualbox viewed same error. i install virtualbox from here  http://www.virtualbox.org/wiki/Linux_Downloads

comment:12 Changed 4 years ago by frank

Hmm, after a reboot, does /etc/init.d/vboxdrv start help as well (instead of /etc/init.d/vboxdrv setup)?

comment:13 Changed 4 years ago by chris.gaeth

Frank,

To answer your first set of questions, yes using the PUEL version and yes it works fine until the next reboot. Now I just tried the vboxdrv start and that worked perfectly. I suspect something is not getting initialized properly at boot now. any suggestions where to look?

comment:14 Changed 4 years ago by frank

Yes. It seems that the vboxdrv script is not executed when your host boots.

What is the output of

ls -l /etc/rc*/*vbox*

? And what is the output of

runlevel

?

comment:15 Changed 4 years ago by frank

Note that I have VBox 3.1.2 running on Karmic here.

comment:16 Changed 4 years ago by chris.gaeth

runlevel
N 2

ls -l /etc/rc*/*vbox*

lrwxrwxrwx 1 root root 17 2009-12-30 12:41 /etc/rc0.d/K20vboxdrv -> ../init.d/vboxdrv
lrwxrwxrwx 1 root root 17 2009-12-30 12:41 /etc/rc1.d/K20vboxdrv -> ../init.d/vboxdrv
lrwxrwxrwx 1 root root 17 2009-12-30 12:41 /etc/rc2.d/S20vboxdrv -> ../init.d/vboxdrv
lrwxrwxrwx 1 root root 17 2009-12-30 12:41 /etc/rc3.d/S20vboxdrv -> ../init.d/vboxdrv
lrwxrwxrwx 1 root root 17 2009-12-30 12:41 /etc/rc4.d/S20vboxdrv -> ../init.d/vboxdrv
lrwxrwxrwx 1 root root 17 2009-12-30 12:41 /etc/rc5.d/S20vboxdrv -> ../init.d/vboxdrv
lrwxrwxrwx 1 root root 17 2009-12-30 12:41 /etc/rc6.d/K20vboxdrv -> ../init.d/vboxdrv

What version of upstart are you running?

comment:17 Changed 4 years ago by frank

Looks ok as well. upstart is 0.6.3-11 from karmic-proposed. Well, the /etc/rc*/ link stuff is not for upstart but upstart should consider these legacy stuff as well. The upstart script

/etc/init/rc.conf

is responsible for this: It contains a line

exec /etc/init.d/rc $RUNLEVEL

So in runlevel 2, it should execute /etc/rc2.d/S20vboxdrv. Does /etc/init/rc.conf exist on your box as well?

comment:18 Changed 4 years ago by chris.gaeth

I think we are on to something here. I do have that file with that line in it. However I noticed that my cups was not starting up properly either. Which lead me to this link  http://www.uluga.ubuntuforums.org/showthread.php?t=1305226&page=2. The s50cups is in the same directory /etc/rc2.d. I tried to down level to 0.6.3-10. No change.

comment:19 Changed 4 years ago by frank

  • Summary changed from Kernel driver not installed (rc=-1908) to Kernel driver not installed (rc=-1908) => Karmic upstart problem?

So most probably an upstart problem. Let's wait for some feedback from the  bug report.

comment:20 Changed 4 years ago by chris.gaeth

Frank,

I had a chance to do some testing this weekend. I even did a full reload again. It is not Upstart. One of the first things I do on my dual core systems is edit the /etc/init.d/rc file and change Concurrency=none to Concurrency=shell. If I do that vboxdrv does not load. Neither does cups. Set it back to none, everything works normally even with the Upstart update.

comment:21 Changed 4 years ago by frank

Well, in /etc/init.d/rc it is clearly stated that enabling concurrency is not possible yet (at least on my system, Ubuntu Karmic) because not all boot scripts are properly adapted. Furthermore, CONCURRENCY=shell is not a valid option here, only CONCURRENCY=startpar and CONCURRENCY=makefile. And I don't see the point in enabling concurrency. So still the question why it works here but not on your systems. Do you have any non-default settings?

comment:22 follow-up: ↓ 24 Changed 4 years ago by RottNKorpse

I just experienced this error on both of my Lucid machines (laptop and desktop)

My Laptop is running the version right before the latest version. (not sure the number)

My Desktop is running the latest version of VB.

I experienced the error on my Desktop yesterday and simply rebooted and it fixed itself.

Today I experienced the error on my Laptop and so I rebooted expecting the same outcome but the error continued so I did some research and found many different solutions but just to make sure before I did any of them I restarted my laptop again and to my surprise it worked fine.

So it cant be a specific version or a specific version of Ubuntu so really I have no idea why it actually happened or why a simple restart fixed it as I didn't change any settings.

comment:23 Changed 4 years ago by jimav

Also for me, running Lucid amd64.

The problem seems to be new (or has come back) with Virtualbox 3.2.8. I did not see this error until updating from the repos last week.

comment:24 in reply to: ↑ 22 ; follow-up: ↓ 25 Changed 4 years ago by rosswille

We also have been experiencing this Kernel driver not installed error on occasion. It seems to occur after we have been running the system on one PC and then boot the same host image on a different PC. This happens only occasionally and a system reboot will sometimes "solve" the problem. Performing /etc/init.d/vboxdrv setup also seems to correct the immediate problem, but the problem will eventually reoccur.

Environment:

  • Host OS: Ubuntu 10.04 (Lucid) i386 desktop
  • VirtualBox: 3.2.6 PUEL for Ubuntu 10.04 i386

This is an important issue for us because the end user does not have the permissions required to run vboxdrv setup.

comment:25 in reply to: ↑ 24 ; follow-up: ↓ 26 Changed 4 years ago by frank

Replying to rosswille:

We also have been experiencing this Kernel driver not installed error on occasion. It seems to occur after we have been running the system on one PC and then boot the same host image on a different PC. This happens only occasionally and a system reboot will sometimes "solve" the problem.

Please don't mix the facts here. A kernel driver not installed usually happens if there is either no module available for the current running kernel or if (for some reason) the startup script which ensures that the kernel modules are loaded is not properly executed during boot. From your description I assume that you just did a kernel update and there was no kernel module available for the new kernel. The task of the recompilation is usually done by DKMS.

If you do NOT update the kernel (even no silent update) then you could try to debug this problem yourself -- I cannot reproduce it here using a plain vanilla Lucid installation. Once the kernel modules are built for the current kernel, they load fine here during every boot. So if you are at the state where the modules are not loaded then try to find out why. Check if there are vboxdrv / vboxnetflt / vboxnetadp modules available for your current kernel. Try modprobe vboxdrv and see what happens.

comment:26 in reply to: ↑ 25 Changed 4 years ago by rosswille

Replying to frank:

Please don't mix the facts here. A kernel driver not installed usually happens if there is either no module available for the current running kernel or if (for some reason) the startup script which ensures that the kernel modules are loaded is not properly executed during boot. From your description I assume that you just did a kernel update and there was no kernel module available for the new kernel. The task of the recompilation is usually done by DKMS.

I am positive I'm not updating to a new kernel. Auto update is off and I've verified that the kernel version is not changing. Also, my bootloader boots the kernel by name, regardless of whether or not newer kernels exist.

If you do NOT update the kernel (even no silent update) then you could try to debug this problem yourself -- I cannot reproduce it here using a plain vanilla Lucid installation. Once the kernel modules are built for the current kernel, they load fine here during every boot. So if you are at the state where the modules are not loaded then try to find out why. Check if there are vboxdrv / vboxnetflt / vboxnetadp modules available for your current kernel. Try modprobe vboxdrv and see what happens.

As mentioned in my original post, this problem appears to be triggered by booting the Ubuntu OS on different hardware than it was running on previously. The vbox drivers do exist for the booted kernel (proven by the fact that a simple reboot will sometimes correct the problem), but for some reason either (1) the startup scripts fail to load the drivers, or (2) the vbox drivers sometimes get an error during their init phase and fail to load. BTW, I have "vboxdrv" listed in my /etc/modules file to autoload the vbox drivers at boot time.

I've been unable to debug this myself because I have not been able to reproduce it personally. But the problem has been reported to me by others and it is a fairly rare occurrence.

I was hoping to learn whether or not the vbox drivers have any dependencies on specific hardware configurations which might explain this behavior.

comment:27 Changed 3 years ago by frank

Is this still an issue? I didn't see any complaints elsewhere ...

comment:28 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

comment:29 Changed 16 months ago by lothario

I still have this problem with 4.2.6 r82870, and so do many others:

The commands below

sudo apt-get install dkms build-essential linux-headers-generic; sudo /etc/init.d/vboxdrv setup

worked for me, but new Linux users are less likely to waste time on forums. If Windows doesn't run in a VM, they'll run it natively.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use