VirtualBox

Ticket #5875 (closed enhancement: duplicate)

Opened 4 years ago

Last modified 4 years ago

[feature-request] Stretch resolution (Zoom-In magnifier) -> duplicate of #5596

Reported by: Technologov Owned by:
Priority: major Component: other
Version: VirtualBox 3.1.2 Keywords:
Cc: Guest type: other
Host type: other

Description

For low resolution guest applications (StarCraft game) there is a need to provide stretching functions for VBox itself.

At least 2x stretcher (software rendering) is necessary. Floating-point stretcher would be even better. (OpenGL anyone?)

It will also improve guests rendering that are running in text-mode (80x25).

This obsoletes wish #1602

-Technologov, 30.12.2009.

Change History

comment:1 Changed 4 years ago by shinsui

+1

I removed StarCraft just for the reason it's only 640x480. That's tiny on a 1280 screen and almost unplayable. When openGL is set to on in the VM I should expect it to be able to play at least 1024x768. It would really improve the game experience on a windows virtual machine.

comment:2 Changed 4 years ago by lwfinger

+1

My grandsons like to play various games that come up in a 640x480 screen. On a real Window$ machine, this is stretched to full screen. The save behavior in a VM would be useful and allow me to dispense with remaining real instances of Window$.

comment:3 Changed 4 years ago by hasherr

+1 There are no strech feature in driver panel (in fact there is no panel) of virtual graphics card, and some old games support only one resolution. So stretch feature would be great.

comment:4 Changed 4 years ago by michael

  • Status changed from new to closed
  • Resolution set to duplicate
  • Summary changed from [feature-request] Stretch resolution (Zoom-In magnifier) to [feature-request] Stretch resolution (Zoom-In magnifier) -> duplicate of #5596

Marking this ticket a duplicate of #5596.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use