VirtualBox

Ticket #5861 (closed defect: fixed)

Opened 4 years ago

Last modified 2 years ago

OSX Host, Win2K Guest, host reports high system CPU use, guest reports low cpu use, in VB 3.1.2

Reported by: iegorman Owned by:
Priority: minor Component: guest smp
Version: VirtualBox 3.1.2 Keywords: cpu use
Cc: Guest type: Windows
Host type: Mac OS X

Description

When running Windows 2000 installed for 2 CPUs in 2-CPU machine with IO-APIC, OSX reports close to 100% CPU use while Windows reports close to zero. However, the Activity monitor does not show a task with high CPU use.

When running Windows 2000 installed for 1 CPUs in 1-CPU machine without IO-APIC, OSX reports high CPU use only when Windows 200 reports hig CPU use.

Similar tickets: 4322, 4922, 5744 (earlier versions of VB)

Attachments

Win2K-2CPU-2009-12-27-20-57-20.log Download (66.1 KB) - added by iegorman 4 years ago.
log file from running W2K in 2-CPU vm with io-apic
Win2K-2CPU-2010-10-15-19-17-38.log Download (67.7 KB) - added by iegorman 4 years ago.
log for VirtualBox 3.2.10, reopen

Change History

Changed 4 years ago by iegorman

log file from running W2K in 2-CPU vm with io-apic

comment:1 Changed 4 years ago by sandervl73

Please retry with 3.2.10 and reopen if required. You shouldn't have this high overhead issue with IO-APIC guests as your CPU supports the hardware solution to deal with this efficiently.

comment:2 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to worksforme

comment:3 Changed 4 years ago by iegorman

  • Status changed from closed to reopened
  • Resolution worksforme deleted

I tried again with VirtualBox 3.2.10 r66523 darwin.x86, and Windows XP SP1, updated to SP4, then updated online, from Microsoft.

When XP is running the idel task at 90% to 95%, VirtualBox guest additions vary from below 2% to about 5% and the host system (Mac OS) is running at 100%, with more than 90% (Mac OS reports this as 180% on the sum of two processors).

Changed 4 years ago by iegorman

log for VirtualBox 3.2.10, reopen

comment:4 Changed 4 years ago by iegorman

The 90% that I reported for Mac OS was the CPU usage fo VirtualBox.

comment:5 Changed 2 years ago by frank

Still relevant with VBox 4.1.6?

comment:6 Changed 2 years ago by iegorman

This problem appears to be fixed in version 4.1.6 running guest Win 2K with 2 CPU in host Mac OS X 10.7.2 (Lion). The Mac OS X process that corresponds to the Windows VM appears to use approximately 7% plus the CPU percentage reported by Windows. For example, if the Windows 2K system reports 3%, Mac OS X will report somewhere around 10% for that VM. Thanks.

comment:7 Changed 2 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use