VirtualBox

Ticket #5787 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

High CPU load when perform specific task in XP guest -> fixed in SVN.

Reported by: kidault Owned by:
Priority: critical Component: network/NAT
Version: VirtualBox 3.1.2 Keywords: cpu load
Cc: Guest type: Windows
Host type: Windows

Description

hardware: dell D630, with 3G RAM host OS:Windows 7 pro guest OS:Windows XP sp3

I met this problem when I upgraded from 3.0.12 to 3.1.0 or 3.1.2.

I have been using the guest XP in the past year, without reinstall. First host OS is Vista, then the Win7. And I kept my virtualbox version as new as possible. Despite some minor problems, they worked perfectly.

When I upgrade from 3.0.12 to 3.1.0(including addition), it was ok at first. But, whenever I started up my MS word, opened some documents, edited for a while, the cpu ran to 100% in both guest and host, and wouldn't come back.

so, I rolled back to 3.0.12, It worked normally again, but MS office (including word and excel) lost response for a while during opening and saving action. I think it has something to do with the downgrade and shared folder, but it's not a very big problem.

Today, I upgrade to 3.1.2. The MS office seems ok. But, when I opened the IE6, and logged into my bank to check my balance. the CPU load ran to 100%, whenever I perform the same task(I have uploaded an pic to indicate the exact step causing the problem). The guest and host kept the 100% load for a long time. Sometime, the load will go back to normal, but the guset XP system become unstable, host is not affacted.

No matter I checked 3D and 2D acceleration or not, the result is the same. The problem has nothing to do with the guest window mode either.

Now, I think it maybe caused by the certification for the bank installed in the IE. Is it possible?

Attachments

WorkXP-2009-12-18-12-37-59(High load).log Download (69.5 KB) - added by kidault 4 years ago.
3.1.2 high cpu load 1st
WorkXP-2009-12-18-13-36-35.log Download (72.4 KB) - added by kidault 4 years ago.
3.1.2 high cpu load 2nd
Clipboard03.png Download (282.8 KB) - added by kidault 4 years ago.
show the web page causing the high load problem

Change History

Changed 4 years ago by kidault

3.1.2 high cpu load 1st

Changed 4 years ago by kidault

3.1.2 high cpu load 2nd

comment:1 follow-up: ↓ 2 Changed 4 years ago by kidault

some addition information for the WorkXP-2009-12-18-13-36-35.log

I waited 10 minutes, nothing happened. "00:07:07.797 Guest Log: VBOXNP: DLL unloaded." is the last during this period.

Then I opened the www.ccb.com in IE6. the line "00:13:42.870 PIT: mode=2 count=0x4ad (1197) - 996.81 Hz (ch=0)" added. I waited for about two minutes, nothing happened.

I logged into my bank account, ran through the routine, soon after I click the "check detail" button, the cpu load jumped.

Changed 4 years ago by kidault

show the web page causing the high load problem

comment:2 in reply to: ↑ 1 Changed 4 years ago by Hachiman

Replying to kidault:

some addition information for the WorkXP-2009-12-18-13-36-35.log

I waited 10 minutes, nothing happened. "00:07:07.797 Guest Log: VBOXNP: DLL unloaded." is the last during this period.

Then I opened the www.ccb.com in IE6. the line "00:13:42.870 PIT: mode=2 count=0x4ad (1197) - 996.81 Hz (ch=0)" added. I waited for about two minutes, nothing happened.

I logged into my bank account, ran through the routine, soon after I click the "check detail" button, the cpu load jumped.

Regarding networking does it change for you anything if you change NAT networking on bridged one?

comment:3 follow-up: ↓ 4 Changed 4 years ago by kidault

The IE6 previously used the NAT to connect the Internet.

Now I uninstalled the guest addition, removed the NAT network card from VM setting. Setting up the IE6 in the guest XP using the http proxy on the host thorugh host-only adapter. The problem seems go away. I will reinstall the guest addition and try more time.

comment:4 in reply to: ↑ 3 Changed 4 years ago by Hachiman

Replying to kidault:

The IE6 previously used the NAT to connect the Internet.

Now I uninstalled the guest addition, removed the NAT network card from VM setting. Setting up the IE6 in the guest XP using the http proxy on the host thorugh host-only adapter. The problem seems go away. I will reinstall the guest addition and try more time.

For switching from NAT to bridged, it isn't required any manipulation with additions. You just may choose the "Bridged Adapter" in the "Attached to:" in Network Adapter Settings. Could you please send me (vasily _dot_ levchenko _at_ Sun _dot_ COM)  pcap file at the moment when CPU usage jump up (you may find useful last 4 steps)?

comment:5 follow-up: ↓ 8 Changed 4 years ago by Hachiman

  • Component changed from other to network/NAT

comment:6 follow-up: ↓ 7 Changed 4 years ago by kidault

I'm Sorry.

But since it has something to do with my bank account, I think it's not security for me to send the packet logging file to someone else.

I will try some not so sensitive website late. If the same problem happene, I will send the file to you immediately.

comment:7 in reply to: ↑ 6 Changed 4 years ago by Hachiman

Replying to kidault:

I'm Sorry.

But since it has something to do with my bank account, I think it's not security for me to send the packet logging file to someone else.

:). Well if connection is secured (e.g. SSL) it is rather secure. What I need to know if there is growing number of retransmits happens and if yes why happens.

I will try some not so sensitive website late. If the same problem happene, I will send the file to you immediately.

Ok, good.

comment:8 in reply to: ↑ 5 ; follow-up: ↓ 9 Changed 4 years ago by kidault

Replying to Hachiman: Hello, I have sent the pcap file to you.

comment:9 in reply to: ↑ 8 Changed 4 years ago by Hachiman

Replying to kidault:

Replying to Hachiman: Hello, I have sent the pcap file to you.

Thank you.

comment:10 follow-up: ↓ 11 Changed 4 years ago by kidault

Get hint from this post  http://forums.virtualbox.org/viewtopic.php?f=6&t=25930&start=30

tonny's suggestion solved the problem for me: "I've been experiencing high CPU loads as well, when using NAT networking (Windows 7 host with Windows XP guest). You should try and completely disable the Windows Firewall in the guest, that did the trick for me."

comment:11 in reply to: ↑ 10 Changed 4 years ago by Hachiman

Replying to kidault:

Get hint from this post  http://forums.virtualbox.org/viewtopic.php?f=6&t=25930&start=30

tonny's suggestion solved the problem for me: "I've been experiencing high CPU loads as well, when using NAT networking (Windows 7 host with Windows XP guest). You should try and completely disable the Windows Firewall in the guest, that did the trick for me."

thanks for update.

comment:12 Changed 4 years ago by Hachiman

We been able reproduce the effect similar you've seen using NAT + Windows firewall. And get solution for our case.

Could you please evaluate the build if it solves fw problem for you?

comment:13 Changed 4 years ago by kidault

Have a try_

comment:14 Changed 4 years ago by mikes82

It worked for me. Thanks

comment:15 Changed 4 years ago by kidault

It seems that the problem has been solved. Before installing the new version, I turned on the ICS in xp. The problem came back soon when I started the program previously causing the high cpu load. Now in the new version, I have run the same program with the ICS on for a while(about 30 minutes). All things runs smoothly now.

comment:16 Changed 4 years ago by Hachiman

Thanks for feedback.

comment:17 Changed 4 years ago by Hachiman

  • Summary changed from High CPU load when perform specific task in XP guest to High CPU load when perform specific task in XP guest -> fixed in SVN.

comment:18 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use