VirtualBox

Ticket #5744 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

High Core 1 Duo host CPU usage when when multi-CPU guest is idle

Reported by: spaaarky21 Owned by:
Priority: major Component: guest smp
Version: VirtualBox 3.1.0 Keywords:
Cc: Guest type: Windows
Host type: Mac OS X

Description

Hopefully this isn't a duplicate. I've seen a lot of similar problem mentioned in forums but most of those were for previous versions, prior to guest SMP support.

Anyway, have a Windows guest that was installed prior to guest SMP support in VBox and it works great but since it was installed when only one CPU was available to the guest, the Windows installation is not using an SMP kernel and the VM never uses more than 50% of the host's CPU time.

So, to take advantage of the host's dual core processor, I created a new VM with two CPU's and installed a fresh copy of Windows. The VM makes use of both of the host's cores now but it uses 100% of the host's CPU time when the guest is idle. I have read about similar issues in the forums but those tended to be related to specific programs like Google Chrome and MS SQL. For me, the guest is unusably slow and it takes an unreasonably long time just to boot the system and get logged in. Running applications in the guest is out of the question.

I am running VirtualBox 3.1.0 on MacOS X 10.6.2 on a MacBook with a Core 1 Duo processor. I had the same problem with VBox 2.x under OS 10.4. I wonder if the problem is specific to my laptop's CPU? A lot of people are using guest SMP successfully on Macs but I assume most of those are running on a Core 2 Duo since the original Core Duo was so short lived.

Attachments

VBox.log Download (58.0 KB) - added by spaaarky21 4 years ago.
VirtualBox log

Change History

Changed 4 years ago by spaaarky21

comment:1 Changed 4 years ago by spaaarky21

After disabling PAE/NX in the processor VM's settings, I reinstalled Windows. Now when the guest is idle, it's doesn't take all of the host's CPU time but the VM's performance is still unusably slow.

comment:2 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #4392. The workaround in 3.0.12 doesn't work on your CPU as it doesn't support the 64 bits extensions.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use