VirtualBox

Ticket #5742 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

Kernel 2.6.32 nmi watchdog problem

Reported by: giaur Owned by:
Priority: blocker Component: host support
Version: VirtualBox 3.1.0 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Latest virtualbox version (3.1) and sixux kernel 2.6.32, grub2. There is a problem with vboxdrv module - it fails to load:

* Starting VirtualBox kernel module
* modprobe vboxdrv failed. Please use 'dmesg' to find out why 

dmesg:

vboxdrv: Trying to deactivate the NMI watchdog permanently...
vboxdrv: NMI watchdog either active or at least initialized. Please disable the NMI
vboxdrv: watchdog by specifying 'nmi_watchdog=0' at kernel command line.
vboxdrv: Trying to deactivate the NMI watchdog permanently...
vboxdrv: NMI watchdog either active or at least initialized. Please disable the NMI
vboxdrv: watchdog by specifying 'nmi_watchdog=0' at kernel command line.
vboxdrv: Trying to deactivate the NMI watchdog permanently...
vboxdrv: NMI watchdog either active or at least initialized. Please disable the NMI
vboxdrv: watchdog by specifying 'nmi_watchdog=0' at kernel command line.
vboxdrv: Trying to deactivate the NMI watchdog permanently...
vboxdrv: NMI watchdog either active or at least initialized. Please disable the NMI
vboxdrv: watchdog by specifying 'nmi_watchdog=0' at kernel command line.
vboxdrv: Trying to deactivate the NMI watchdog permanently...

There is nmi_watchdog option in kernel command line already, but it won't change anything:

cat /boot/grub/grub.cfg | grep linux:

### BEGIN /etc/grub.d/10_linux ###
        linux   /boot/vmlinuz-2.6.32-0.slh.1-sidux-amd64 root=UUID=7ff4fe9c-3dc2-49d2-8977-2f45c0be989a ro  quiet splash vga=791 nmi_watchdog=0
        linux   /boot/vmlinuz-2.6.32-0.slh.1-sidux-amd64 root=UUID=7ff4fe9c-3dc2-49d2-8977-2f45c0be989a ro single
### END /etc/grub.d/10_linux ###

OS: Debian Sid, 64-bit.

I've also tried this on my laptop. In this case, /etc/init.d/vboxdrv start fails, but modprobe vboxdrv works, but only if nmi_watchdog=0 is the first option. But this does not help for my PC.

Change History

comment:1 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #4529.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use