VirtualBox

Ticket #5734 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

Saved VM cannot be started after resuming Linux host

Reported by: letezo Owned by:
Priority: major Component: VM control
Version: VirtualBox 3.1.0 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Environment

  • VirtualBox 3.1.0
  • Host: Ubuntu 9.10 amd64
  • Guest: Windows Server 2003 (latest VBox Guest Additions is installed, then rebooted normally)
  • RAM: 8G
  • CPU: Intel Q6600

How to reproduce

  1. Start Windows VM
  2. Save VM's state using VirtualBox
  3. Wait for the state fully written to disk
  4. Suspend the host (do not hibernate, just suspend)
  5. Resume the host
  6. Start the VM

The VM will load (at least it seems), but instead of showing up its screen it will stop with this error dialog (also attached a screenshot):

Failed to start the virtual machine windows-2003.
VD: error VERR_NOT_SUPPORTED opening image file '/home/fviktor/.VirtualBox/HardDisks/Windows-2003.vdi' (VERR_NOT_SUPPORTED).
VD: error VERR_NOT_SUPPORTED opening image file '/home/fviktor/.VirtualBox/HardDisks/Windows-2003-D.vdi' (VERR_NOT_SUPPORTED).
Failed to load unit 'pgm' (VERR_SSM_INTEGRITY_REC_TERM_CRC).

Details:

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: Console
Interface: IConsole {6375231a-c17c-464b-92cb-ae9e128d71c3}

The guest's display remains black and at its original size (no guest screen resolution restored).

After this point you have to discard the VM state and start it again.

It can potentially cause data loss in the guest.

Please note, that without suspending the host everything works fine and saved VMs can be resumed reliably otherwise.

Attachments

Screenshot-VirtualBox-Error-Dialog.png Download (49.1 KB) - added by letezo 4 years ago.
Screenshot of the VirtualBox error dialog
windows-2003.xml Download (9.0 KB) - added by letezo 4 years ago.
VM configuration file
VBox.log Download (70.3 KB) - added by letezo 4 years ago.
Log file of the broken session (after resuming the host)
VBox.log.1 Download (70.3 KB) - added by letezo 4 years ago.
Log of my first attempt to resume the VM after resuming the host (I tried it twice)
VBox.log.2 Download (72.0 KB) - added by letezo 4 years ago.
It is the session ended by saving the VM's state before suspending the host (it reported no user visible error messages)

Change History

Changed 4 years ago by letezo

Screenshot of the VirtualBox error dialog

Changed 4 years ago by letezo

VM configuration file

Changed 4 years ago by letezo

Log file of the broken session (after resuming the host)

Changed 4 years ago by letezo

Log of my first attempt to resume the VM after resuming the host (I tried it twice)

Changed 4 years ago by letezo

It is the session ended by saving the VM's state before suspending the host (it reported no user visible error messages)

comment:1 Changed 4 years ago by letezo

This problem is reproducible, since I observed it the second time.

I just did not report my first one, which originally happened on a 3.0.x release.

comment:2 Changed 4 years ago by letezo

I'm not sure about my selection of the "VM Control" component for this ticket.

Please change the ticket if needed.

Thank you.

comment:3 Changed 4 years ago by hasinasi

Is this by any chance related to this:  http://forums.virtualbox.org/viewtopic.php?f=1&t=26340&p=121027&hilit=saved#p121027 In my case (kubuntu 9.10-32bit host, VB 3.1.2), this did the trick.

comment:4 Changed 4 years ago by letezo

No. As you can see from my logs I use the standard location for everything and it has not been changed when the bug happened.

Additional observation

I haven't seen this bug since I upgraded my machine to Core i7. Either Ubuntu fixed something in its suspend support or changing the processor/motherboard fixed this.

comment:5 Changed 4 years ago by letezo

I guess this is something specific to the Core 2 CPUs (Q6600 was a Core 2 Quad).

comment:6 Changed 4 years ago by letezo

The difference between my old and current VM settings:

  • The Q6600 does not support nested paging, so it was turned off.
  • The Core i7 supports nested paging, so I turned it on.

comment:7 Changed 4 years ago by sandervl73

If the difference is nested paging, then turning it off should show the same problem. Could you test this?

comment:8 Changed 4 years ago by bewst

I think I have the same problem on my Core 2 Duo Mac host. My XP guest keeps locking up. Last time, instead of power cycling, I saved the machine state. This is what happened when I tried to resume it later:

Result Code: 
NS_ERROR_FAILURE (0x80004005)
Component: 
Console
Interface: 
IConsole {6375231a-c17c-464b-92cb-ae9e128d71c3}

comment:9 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 4.0.4.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use