VirtualBox

Ticket #5723 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

USB Devices Menu Grayed Out - VirtualBox 3.1.0

Reported by: HipHoppity Owned by:
Priority: critical Component: other
Version: VirtualBox 3.1.0 Keywords: gray grey usb devices menu grayed greyed
Cc: Guest type: other
Host type: other

Description

I've run into a strange problem after upgrading a Mac OSX Host from VirtualBox 3.0.12 to the new 3.1.0 build. The "USB Devices" menu for the Guest is completely grayed out.

This problem has been listed in the forum for about a week. Please see images and further details at forum post:  http://forums.virtualbox.org/viewtopic.php?f=8&t=25474

Here's what I'm running on this machine:

Host = Mac OSX Leopard ( v. 10.5.8 )
Guest = Windows Pro XP SP3
VirtualBox 3.1.0 PUEL version (installer package VirtualBox-3.1.0-55467-OSX.dmg)
USB Controller Enabled in Guest
Guest Additions 3.1.0 installed

Interestingly, I can still attach to USB devices through the icon in the lower right-hand-side of the Guest window.

I thought perhaps reinstalling VBox 3.1.0 might fix this problem with the grayed out USB Devices menu. I've tried two reinstalls so far without success.

I can revert my WinXP VM back to VBox 3.0.12 and then use the USB Devices menu just as before -- everything works fine. The problem is reproducible.

I couldn't locate any info on resolving this problem. This appears to be a bug. Please let me know if you have questions or need further details to resolve this problem.

VBox log attached.

Attachments

VBox 3.1.0 WinXP.log Download (80.8 KB) - added by HipHoppity 4 years ago.
VBox 3.1.0 Log for WinXP Guest on Mac OSX Guest

Change History

Changed 4 years ago by HipHoppity

VBox 3.1.0 Log for WinXP Guest on Mac OSX Guest

comment:1 Changed 4 years ago by SwordAngel

I have the exact same issue on a Mac OS X 10.6.2 host.

comment:2 follow-up: ↓ 3 Changed 4 years ago by frank

A colleague just tested VBox 3.1.0 on Mac OS X 10.5.8 (Leopard), works fine for him.

comment:3 in reply to: ↑ 2 Changed 4 years ago by HipHoppity

Replying to frank:

We've had a couple of people report in with this problem. It may well be a minority of users that encounter this bug. Please let us know if additional VBox logs or other information we can provide will help you locate this bug.

I appreciate your taking the time to look into it.

comment:4 Changed 4 years ago by HipHoppity

I installed VBox 3.1.2 today and found that the "USB Devices" menu is back again (working like VBox 3.0.12). Perhaps one of the fixes in the VBox 3.1.2 update helped out with this problem as well.

See forum post for details =>  http://forums.virtualbox.org/viewtopic.php?f=8&t=25474

For those of you that reported having the grayed-out USB Devices menu -- please give build 3.1.2 a try to see if this solves the problem for you.

comment:5 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use