VirtualBox

Ticket #5719 (closed defect: worksforme)

Opened 13 years ago

Last modified 12 years ago

xorg restarts

Reported by: DaleEMoore Owned by:
Component: other Version: VirtualBox 3.1.0
Keywords: Cc:
Guest type: Windows Host type: Linux

Description

This ticket is based on an unresolved Forum post here  http://forums.virtualbox.org/viewtopic.php?t=25659.

In a new Ubuntu 9.10 install with VirtualBox OSE and also PUEL Xorg restarts just like I'd run "sudo /etc/init.d/gdi restart" every few minutes. It does not do the restart if I'm not using the machine. It does not do the restart if I am not using VirtualBox and rmmod the 3 vbox modules.

I moved the HDs to another machine that's the same hardware and get the same behaviour.

I haven't noticed anything in ~/.VirtualBox/Machines/XP/Logs/VBox.log, /var/log/messages, /var/log/Xorg.0.log, or /var/log/gdm/:0.log that I recognize as helpful, but I'm attaching them hoping your greater experience finds something useful.

Any suggestions are appreciated. Dale E. Moore

Attachments

VBox.log Download (47.1 KB) - added by DaleEMoore 13 years ago.
Xorg.0.log Download (51.1 KB) - added by DaleEMoore 13 years ago.
0.log Download (45.6 KB) - added by DaleEMoore 13 years ago.
messages.txt.gz Download (246.4 KB) - added by DaleEMoore 13 years ago.
VBox.2.log Download (53.0 KB) - added by HotShotDJ 13 years ago.

Change History

Changed 13 years ago by DaleEMoore

Changed 13 years ago by DaleEMoore

Changed 13 years ago by DaleEMoore

Changed 13 years ago by DaleEMoore

comment:1 Changed 13 years ago by DaleEMoore

Interestingly in the time it took me to compose this bug, xorg restarted twice. Both times I had typed ALT-TAB to shift from Firefox to gnome-terminal to do some further research. I believe the xorg restart occurred as I released the ALT-TAB.

comment:2 Changed 13 years ago by michael

That is a crash in the Intel graphics driver. Could you try reporting it on Launchpad and updating this ticket with any relevant information?

comment:4 Changed 13 years ago by HotShotDJ

I am having the same issue, although not as frequently as Dale. After a while, my desktop freezes and then the system reboots. I have tried disabling 3D and 2D Acceleration in VirtualBox to no effect.

Ubuntu 9.10 VirtualBox 3.1.0 PUEL Windows XP Pro Guest w/ Windows Guest Additions

Changed 13 years ago by HotShotDJ

comment:5 Changed 13 years ago by DaleEMoore

Hi HotShotDJ;

Thanks for speaking up!

You might have noticed that it has been suggested that this is a bug in xorg and to create a ticket at Launchpad to address the issue. Please consider adding your notes to the Ubuntu Launchpad but, also.

Posted to Ubuntu Launchpad here  https://bugs.launchpad.net/xserver-xorg-driver-vesa/+bug/495916.

Metta, Dale E. Moore

comment:6 Changed 13 years ago by HotShotDJ

Hello, Dale --

At your request, I've added a note to the above-listed Launchpad bug. On my system, I've noticed that the problem has only occurred for me when running my laptop "dual-headed" with the VirtualBox guest running full-screen on the external monitor. Odd, to say the least.

comment:7 Changed 13 years ago by DaleEMoore

I wiped the boot HD and installed Ubuntu 9.10. Copied .VirtualBox back and it's running without problems now.

comment:8 Changed 13 years ago by HotShotDJ

I've also had a return to normal operation, although I didn't do a reinstall. There has been two updates to the nvidia driver and one update to VirtualBox since I posted my comment. I've been using my system as described in my previous post for two days (total of 12 hours) without a problem. I can't say if it was the nvidia or the VirtualBox updates that fixed it, but it appears to be fixed now.

comment:9 Changed 13 years ago by HotShotDJ

I spoke too soon. I experienced the crash/reboot again today. This time, I was not running VirtualBox, although the modules were loaded. I have removed my custom kernel and will try to replicate the crash.

comment:10 Changed 12 years ago by HotShotDJ

Just a follow-up. I'm now using Ubuntu 10.04 (Lucid) with the NVidia driver (195.36.24) and VirtualBox PUEL (Version 3.2.8). I have not experienced a problem since upgrading to Lucid in April. It is probably safe to close this bug.

comment:11 Changed 12 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

Thanks for the feedback, let's close this ticket then.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use