VirtualBox

Ticket #5716 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

3.1 sends too few mouse wheel events

Reported by: scott_barrett Owned by:
Priority: major Component: other
Version: VirtualBox 3.1.0 Keywords:
Cc: Guest type: Solaris
Host type: Mac OS X

Description

In VBox 3.1.0 on Mac OS 10.5.8, my Solaris 10 guest receives far fewer button 4 and 5 events (mouse scroll wheel or touchpad two-finger scrolling) than in prior versions of VBox, resulting in jerky scrolling. The problem is seen with both 3.1.0 and 3.0.12 guest additions.

Reverting to 3.0.12 restores smooth scrolling (using either 3.1.0 or 3.0.12 guest additions).

Attachments

solaris10-09-05-x86-2009-12-09-16-57-28.log Download (47.1 KB) - added by scott_barrett 4 years ago.
3.1.0 VB log
xev.log Download (8.2 KB) - added by scott_barrett 4 years ago.
3.1.0 xev log
solaris10-09-05-x86-2009-12-09-16-14-30.log Download (68.4 KB) - added by scott_barrett 4 years ago.
3.0.12 VB log
xev.2.log Download (38.0 KB) - added by scott_barrett 4 years ago.
3.0.12 xev log

Change History

Changed 4 years ago by scott_barrett

3.1.0 VB log

Changed 4 years ago by scott_barrett

3.1.0 xev log

Changed 4 years ago by scott_barrett

3.0.12 VB log

Changed 4 years ago by scott_barrett

3.0.12 xev log

comment:1 Changed 4 years ago by scott_barrett

The two attached logs from xev attempt to demonstrate the different number of button 4 and button 5 events generated by the "same" two-fingered scrolling trackpad swipes. In each case, a two-fingered swipe was performed in each direction for the entire vertical extent of the trackpad. I tried to make the swipes at the same speed for the two tests.

In the 3.0.12 case, the first swipe was up, the second down. In the 3.1.0 case the first swipe was down, the second up (followed by a left click).

comment:2 Changed 4 years ago by sandervl73

  • Host type changed from other to Mac OS X
  • Guest type changed from other to Solaris

comment:3 Changed 4 years ago by lazylady

I can confirm this on Windows XP Guest, OS X 10.6 Host running VBox 3.1.0.

comment:4 Changed 4 years ago by poetzsch

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #5672.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use