VirtualBox

Ticket #5706 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

When my machine goes to sleep for power management reasons, VirtualBox crashes and pulls the machine down.

Reported by: dlafferty Owned by:
Priority: critical Component: other
Version: VirtualBox 3.1.0 Keywords:
Cc: Guest type: other
Host type: Windows

Description

Sorry for delay, problem was first noted on forum at  http://forums.virtualbox.org/viewtopic.php?f=6&t=24104&p=108443#p108443

Although WinDbg reports that the process is VirtualBox, but I can't pin point the driver (see debugging details below).

Debugging Details:


EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%08lx referenced memory at 0x%08lx. The memory could not be %s.

FAULTING_IP: +0 fffffa80`042de32a ?? ???

EXCEPTION_PARAMETER1: 0000000000000000

EXCEPTION_PARAMETER2: ffffffffffffffff

READ_ADDRESS: ffffffffffffffff

DEFAULT_BUCKET_ID: VISTA_DRIVER_FAULT

BUGCHECK_STR: 0x1E

PROCESS_NAME: VirtualBox.exe

CURRENT_IRQL: 2

LAST_CONTROL_TRANSFER: from fffff80001a5ba57 to fffff80001a79450

STACK_TEXT: fffffa600470dee8 fffff80001a5ba57 : 000000000000001e ffffffffc0000005 fffffa80042de32a 0000000000000000 : ntKeBugCheckEx fffffa600470def0 fffff80001a792a9 : fffffa600470e628 fffffa6009cc5000 fffffa600470e6d0 fffffa6009ce2980 : nt! ?? ::FNODOBFM::`string'+0x29117 fffffa600470e4f0 fffff80001a77e8d : fffff80001b9bdc0 fffff80001b0813f fffffa8004274060 fffff88000000100 : ntKiExceptionDispatch+0xa9 fffffa600470e6d0 fffffa80042de32a : 00000000bfaea000 fffffa80042e1978 fffffa600014cc12 0000000000000001 : ntKiGeneralProtectionFault+0xcd fffffa600470e860 00000000bfaea000 : fffffa80042e1978 fffffa600014cc12 0000000000000001 0000000000008000 : 0xfffffa80`042de32a fffffa600470e868 fffffa80042e1978 : fffffa600014cc12 0000000000000001 0000000000008000 fffff88008b05140 : 0xbfaea000 fffffa600470e870 fffffa600014cc12 : 0000000000000001 0000000000008000 fffff88008b05140 fffffa6001bbf000 : 0xfffffa80`042e1978 fffffa600470e878 0000000000000001 : 0000000000008000 fffff88008b05140 fffffa6001bbf000 fffffa80042dd148 : 0xfffffa60`0014cc12 fffffa600470e880 0000000000008000 : fffff88008b05140 fffffa6001bbf000 fffffa80042dd148 fffffa80081de040 : 0x1 fffffa600470e888 fffff88008b05140 : fffffa6001bbf000 fffffa80042dd148 fffffa80081de040 0000000000000000 : 0x8000 fffffa600470e890 fffffa6001bbf000 : fffffa80042dd148 fffffa80081de040 0000000000000000 fffffa8004274060 : 0xfffff880`08b05140 fffffa600470e898 fffffa80042dd148 : fffffa80081de040 0000000000000000 fffffa8004274060 fffffa8003c25010 : 0xfffffa60`01bbf000 fffffa600470e8a0 fffffa80081de040 : 0000000000000000 fffffa8004274060 fffffa8003c25010 fffffa6009cc5000 : 0xfffffa80`042dd148 fffffa600470e8a8 0000000000000000 : fffffa8004274060 fffffa8003c25010 fffffa6009cc5000 fffffa8005618c80 : 0xfffffa80`081de040

Attachments

Mini110909-02 - Copy.dmp Download (280.2 KB) - added by dlafferty 4 years ago.
061410-28906-01.dmp Download (280.0 KB) - added by DoctorBrown 4 years ago.
Minidump file from DoctorBrown
061410-17940-01.dmp Download (279.7 KB) - added by DoctorBrown 4 years ago.

Change History

Changed 4 years ago by dlafferty

comment:1 Changed 4 years ago by sandervl73

  • Priority changed from major to critical

Could you start the VM that was running and attach its VBox.log? (don't suspend your computer)

comment:2 Changed 4 years ago by sandervl73

  • Host type changed from other to Windows

comment:3 Changed 4 years ago by sandervl73

By the way, are you using a USB device in that VM?

comment:4 Changed 4 years ago by dlafferty

I am now, but I can't recall if I was using one then. I'll go with 'probably'.

comment:5 follow-up: ↓ 6 Changed 4 years ago by DoctorBrown

I'm having the same Blue Screen. But mine will also happen on system shutdown. The system will hang on shutdown and if I leave it running, instead of doing a system reset, the BS will occur. This also happened on my previous install of VBox 3.1.4 except the driver was called VBoxNetFlt. This will occur even if I don't run Vbox. I just recently installed Vbox 3.2.4 the week of June7, 2010.

Attached is to recent minidumps of the failure.

Changed 4 years ago by DoctorBrown

Minidump file from DoctorBrown

Changed 4 years ago by DoctorBrown

comment:6 in reply to: ↑ 5 Changed 4 years ago by misha

Replying to DoctorBrown: Unfortunately we are not able to reproduce this issue, and minidump does not provide any useful info about the root cause of the power state change failure.
It would be great if you could provide me a  kernel memory dump (rather than a minidump) for the BSOD. If you can provide one then please post me an email at mikhail dot sennikovsky at sun dot com so I can tell you an FTP server for uploading the file.

comment:7 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use